WebStorm 10 Hanging Constantly

I'm running into an issue on my Mac (Yosemite 10.10.3). Webstorm (10.0.2) hangs a lot and it causes me to have to kill the process and restart 10's of times per day. It never unhangs and I've closed every application that might even remotly share the same paths. I've also disabled a few plugins, git being one of them as I was using SourceTree and was worried it was competing for locks. This didn't help.

I am doing typescript /nodejs development in WebStorm right now and have a few days left on eval before I buy it. I really like it and will likely buy it but this hang makes it painful to do anyting. 90% of the time it hangs when I'm about to change a configuration or run a refactor command which is painful to restart every time.

After I kill the process (Force Kill form Dock) I notice that it leaves this command running:

/usr/local/bin/node /Applications/WebStorm.app/Contents/plugins/JavaScriptLanguage/typescriptCompiler/bridge.js -id=1430874904974 -servicePath=/Applications/WebStorm.app/Contents/plugins/JavaScriptLanguage/typescriptCompiler/external/typescriptServices.js -port=63340 -host=127.0.0.1 -mainFilePath=/MY_PATHS_HERE/typescript/server.ts --sourceMap --module CommonJS --target es5 --outDir /MY_PATHS_HERE/

I just manually kill that otherwise I have 10-20 of these running which I thnk leads to the hangs getting worse and worse.

Attached is the file from a jstack I ran on the last hung process before killing it.

If anyone can help with this I would appreciate it.

Thanks!



Attachment(s):
webstorm-jstack.txt.zip
3 comments
Comment actions Permalink

What's your JDK version (Help | About?

0
Comment actions Permalink

java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

0

Please sign in to leave a comment.