Trapped in PhpStorm Window

Hi,

within a short period of time I found myself trapped in the PhpStorm window twice. I wasn't able to move the mouse to the secondary or the tertiary monitor (PhpStorm is maximized on the primary monitor standing in the middle). IIRC, I couldn't move the mouse to the taskbar of the primary monitor, too.

I've tried to search the settings and the menu, Google and this forum, but I probably didn't use the correct search terms. I guess this is some PhpStorm feature? At least it only occurred when using PhpStorm, and I could "fix" the problem by closing PhpStorm and starting it again. When minimizing PhpStorm instead of closing it, I could move the mouse normally, but was trapped again after restoring the minimized window.

Could someone please tell me how this "mouse lock" can be unlocked without exiting PhpStorm? Unfortunately I'm not sure how I initiated it - I probably used some Hotkey accidentally. I forgot about the first time, but the second time I used Ctrl + Shift + AltGr + N (German keyboard) to find a symbol name - which did indeed work, so I don't know what could have initiated the problem. Maybe I pressed some additional key? Strange that this occurred twice now - I never experienced a similar issue since starting to use PhpStorm in August.

I'm using PhpStorm 8.0.3 Build #PS-139.1348 32-bit on a Windows 7 x64 system.

I'd be very grateful for any hints regarding this issue.

Cheers,
Jan

2 comments
Comment actions Permalink

Please try File | Invalidate Caches and restart.
Also please try is issue reproducible in the latest EAP: http://confluence.jetbrains.com/display/PhpStorm/PhpStorm+Early+Access+Program

0
Comment actions Permalink

Thank you very much for your reply. So I guess this isn't a feature...  ;)

After restarting PhpStorm, it works as expected, so I'm not sure if invalidating the caches is necessary or helpful. I'll try it nevertheless.

The issue hasn't occurred again since my posting, and since I don't know why it happened, it's really hard to reproduce it at all, even in version 8.0.3...

Cheers,
Jan

0

Please sign in to leave a comment.