Subversion 1.4 and IDEA 6.0.2: how to revert to 1.3?

ok, so i clicked that magic checkbox saying "yes i consent to upgrading to v1.4
of subversion," without fully realizing the repercussions (and yes, despite the
warnings).

i occasionally do svn work inside IDEA. i like/prefer the command line, which
now no longer works. the output of any command line operation is now:

" svn: This client is too old to work with working
copy 'xyz'; please get a newer Subversion client "

i need to upgrade to v1.4. except that the ubuntu repositories
don't yet offer a v1.4. i know i could probably install it from source but i prefer
not to.

so here's my question: how do i "undo" my decision to use 1.4? i've done only
one commit since. i thought i'd ask before guessing.

i'm guessing i need to revert that last commit and then perhaps check out
a fresh copy and then re-apply the commit using a 1.3 client.

thanks, / eitan

2 comments
Comment actions Permalink

I don't think you have to revert the commit.
Simply check out a fresh copy using a 1.3 client and work with those files.


Eitan Suez wrote:

ok, so i clicked that magic checkbox saying "yes i consent to upgrading to v1.4
of subversion," without fully realizing the repercussions (and yes, despite the
warnings).

i occasionally do svn work inside IDEA. i like/prefer the command line, which
now no longer works. the output of any command line operation is now:

" svn: This client is too old to work with working
copy 'xyz'; please get a newer Subversion client "

i need to upgrade to v1.4. except that the ubuntu repositories
don't yet offer a v1.4. i know i could probably install it from source but i prefer
not to.

so here's my question: how do i "undo" my decision to use 1.4? i've done only
one commit since. i thought i'd ask before guessing.

i'm guessing i need to revert that last commit and then perhaps check out
a fresh copy and then re-apply the commit using a 1.3 client.

thanks, / eitan

0
Comment actions Permalink

I don't think you have to revert the commit.
Simply check out a fresh copy using a 1.3 client and
work with those files.


thanks! you're right. actually i went even more minimal:
i deleted the one directory that had the svn 1.4 metainfo
and "svn update" did the trick.

/ eitan

0

Please sign in to leave a comment.