IDEA and Blackdown JDK 1.4.1

It seems I can't use IDEA under Blackdown Linux JDK. Blackdown 1.4.1 is based on Sun 1.4.1_01, but the internal version number is just 1.4.1, so IDEA complains about that, saying it needs 1.4.1_01 or higher.

I think there should be a way to force IDEA to run on any JDK the user wishes (ie, just remove the check and let the program run at the user's risk).

Blackdown Linux JDK offers huge improvements on Java2D performance over Sun JDK, so IDEA should run faster under it. Please consider that :)

4 comments

The following links to an email on the java-linux list concerning this issue.

http://www.mail-archive.com/java-linux%40java.blackdown.org/msg15264.html

Unfortunately there haven't been any responses yet from the Blackdown team.

Kelly

On Wed, 05 Mar 2003 19:06:52 +0000, Chris Bartley wrote:

See http://www.intellij.net/tracker/idea/viewSCR?publicId=9894


0


"Marcus Brito" <pazu@animegaiden.com.br> wrote in message
news:15412115.1046883958904.JavaMail.jrun@is.intellij.net...

It seems I can't use IDEA under Blackdown Linux JDK. Blackdown 1.4.1 is

based on Sun 1.4.1_01, but the internal version number is just 1.4.1, so
IDEA complains about that, saying it needs 1.4.1_01 or higher.
>

I think there should be a way to force IDEA to run on any JDK the user

wishes (ie, just remove the check and let the program run at the user's
risk).
>

Blackdown Linux JDK offers huge improvements on Java2D performance over

Sun JDK, so IDEA should run faster under it. Please consider that :)

What exactly are the advantages of Blackdown ?
As far as I can see from their web site, they are also using the Hotspot
JVM.


0

I dodn't see any performance improvments with Blackdown JDK.
AFAIK Sun and Blackdown use the same source tree. Moreover it seems like a
big myth that Blackdown under Linux overperforms SUN even under Win32.
IMHO, it's not true. I see only one benefit of Blackdown: it's compiled by
GCC 3.2

Best regards,
Vladimir Kondratyev
_____________________
JetBrains


Marcus Brito wrote:

It seems I can't use IDEA under Blackdown Linux JDK. Blackdown 1.4.1 is
based on Sun 1.4.1_01, but the internal version number is just 1.4.1, so
IDEA complains about that, saying it needs 1.4.1_01 or higher.

I think there should be a way to force IDEA to run on any JDK the user
wishes (ie, just remove the check and let the program run at the user's
risk).

Blackdown Linux JDK offers huge improvements on Java2D performance over
Sun JDK, so IDEA should run faster under it. Please consider that :)


--
Best regards,
Vladimir Kondratyev
________________
JetBrains

0

Please sign in to leave a comment.