latest tomcat and intellij seem not to work

I have a web application
One one box i am using Apache Tomcat/4.0.4 and intellij 301 build 694. That
config works on xp fine

But i can not get Apache Tomcat 4.1.18 and 695 to work on another xp box.
When i try to start tomcat from the ide, it fails immediately with the error
listed below

does anyone have this config working and did they have to do anything to
make it work?

thanks for any help

the error i get when i try to start the webapp is :
org.apache.commons.logging.LogConfigurationException:
java.lang.NullPointerException
at org.apache.commons.logging.LogFactory.newFactory(LogFactory.java:558)
at org.apache.commons.logging.LogFactory.getFactory(LogFactory.java:355)
at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:409)
at org.apache.commons.digester.Digester.(Digester.java:345)
at
org.apache.catalina.startup.Catalina.createStartDigester(Catalina.java:280)
at org.apache.catalina.startup.Catalina.start(Catalina.java:441)
at org.apache.catalina.startup.Catalina.execute(Catalina.java:400)
at org.apache.catalina.startup.Catalina.process(Catalina.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39
)
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl
.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:203)
Caused by: java.lang.NullPointerException

at org.apache.commons.logging.LogFactory.newFactory(LogFactory.java:543)



3 comments

RTFM. Version 4.0.6 only for the plugin

0

Randy,

Have you tried replacing the Commons Logging component with the most recent one from Jakarta. I noticed that they made significant changes to the method which threw this Exception. If it doesn't work, it might atleast shed some more insight as to what is going on.

Justin

0

Justin, it doesn't matter there are more issues than that, IDEA's docs specify that the plugin ONLY works with Tomcat 4.0.6. FURTHER Tomcat 4.1.x does NOT have ANY JSP debugging code in it, which means that asside from just running Tomcat within IDEA there is no real good reason to use it with IDEA. You might as well setup and run Tomcat separately not within idea and still do you coding in idea.

0

Please sign in to leave a comment.