CVS login doesn't seem to work on me

I use IDEA 692 on Linux. JDK 1.4

(CVS) 1.11.2-debian

I initially extracted the CVS tree from the command line,. Then I created a project to work on it.
I am now trying to use the built-in functionality.
Unfortunately nothing works. Diff, update and other commands end up with a message in the status bar: CVS 'Fetch file' command completed with status 1.

I decided to try to run checkout from IDEA, even though I already did it from the command line.

Doing a checkout from the explorer pane selecting the root dir prints the following on the console

/usr/bin/cvs -z 9 -d :pserver:guest@cvs.tigris.org:/cvs checkout -P scarab
Fatal error, aborting.
guest: no such user

CVS command finished execution.

If I do an update on the root dir from the CVS pane:

/usr/bin/cvs -z 9 update -d -P
Fatal error, aborting.
guest: no such user

CVS command finished execution.


All this works OK on the command line.

Any IDEA?

Also note that I cannot copy/paste text from the CVS console. 'Copy selected text' and CTRL-C do not work in my environment. But this is probably a Gnome 2.2/JDK 1.4 clipboard problem.

J.

I've read http://www.intellij.com/docs/CVS.pdf

4 comments

I am still stuck on this issue. I tried creating a new project from scratch, configure the CVS repository and then do a chackout, but it still fails. On the CVS console:

-


/usr/bin/cvs -d :pserver:guest@cvs.tigris.org:/cvs checkout -P scarab
cvs checkout: warning: failed to open /homer/jerome/.IntellijIdea/system/sca_ipr71e012fd.cvspass
Fatal error, aborting.
guest: no such user

CVS command finished execution
-



This cvspass file error is new to me.
CVS still works OK with the same command on the command line.
Still using build 692 with JDK 1.4.1_01 from Sun.

Is there anything I am missing, such as an environment variable?

Jerome

0

Same thing happens for me, and I'm OS X. I thought this was an OS X issue for a while there, but I guess not! COOL! (Well... sort of)

0

I finally managed to solve my problem.
To do so, I did the following:
- renamed ~/.cvsrc into ~/.cvsrc.old (had not effect)
- renamed ~/.cvspass into ~/.cvspass.old (had no effect)
- copied my ~/.cvspass.old to ~/.IntellijIdea/system/sca_ipr71e012fd.cvspass

worked!

So the solution might be only to copy your ~/.cvspass into the correct missing file in IDEA.
But if it still doesn't work try removing thos ~/.cvsrc and ~/.cvspass files.

The file was not modified by IDEA.

Reported there:
http://www.intellij.net/tracker/idea/viewSCR?publicId=9995

0

Robert, not sure what version of CVS you are running but I was having all sorts of problems with the version that ships with OS X, 1.10. I have since upgraded CVS to version 1.11 via Fink and it works great.

Matthew

0

Please sign in to leave a comment.