Node requires No longer Works for node_modules after Install of Webstorm 10

I just upgrade to Webstorm 10 and in the upgrade options told it to retain existing settings.

Seems to have retained it, I checked in the preferences after.

But now any npm modules I've installed no longer work.  When I say work, I mean in Webstorm, I can't Command + Click to resolve those modules.

The require works if you include a file in my website (such as below you can see I included before_hooks.js), but node_module requires no longer work.

look at the zombie require and one example, I can't resolve it...

Screen Shot 2015-04-09 at 12.58.04 AM.png

my development/website/package.json has:
Screen Shot 2015-04-09 at 12.08.39 AM.png

3 comments
Comment actions Permalink

Do you mean that you can't navigate to 'zombie' module by Ctrl+clicking 'require('zombie')'? It's a known regression in WS 10 (https://youtrack.jetbrains.com/issue/WEB-16145), it's fixed today. Fix will likely be available in the next minor update

0
Comment actions Permalink

Weird thing is it WAS working.  I had installed Phantom-node npm module and I was able to command + click it.  But all of a sudded it stopped working for any required modules I import into my .js files recently.

I am talking command + click, not control + click, this is on a Mac OS.

0
Comment actions Permalink
I am talking command + click, not control + click, this is on a Mac OS.

it doesn't matter - the issue is not OS-specific, and Ctrl+click on Windows/Linux does exactly the same thing as Cmd+click on Mac

0

Please sign in to leave a comment.