"JNDI port configuration not found" error - IDEA 6.0.1 and JBoss 4.0.5.GA

I just upgraded to IDEA 6 a few days ago, as I wanted to start on EJB3 development using JBoss.

I downloaded the latest JBoss 4.0.5.GA webstart installer and selected the ejb3 configuration.

When trying to create a new runconfiguration for a local JBoss, I can get everything configured except it says "JNDI port configuration not found" in the bottom.

I can configure it up against earlier versions of JBoss (that do not have EJB3) and there is no problem configuring a riun config for those.

Have things changed in the latest JBoss versions that break the JBoss module in IDEA?

What exactly is the JBoss module looking for, so I could possibly move a configuration to where its looking.

Thanks

3 comments

The problem is that in JBoss 4.0.5 the location of the naming service configuration has been changed once again. And as IDEA 6.0.1 has been released prior to the release of JBoss 4.0.5, this changed configuration is not supported yet.

Full support for JBoss 4.0.5 including the changed naming service configuration will be added in IDEA 6.0.2.

In the meantime you may copy the file deploy/naming.sar/META-INF/jboss-service.xml to deploy/naming-service.xml where the configuration will be found.

0

Thanks for the link. Although I liked the way Eclipse worked for highlighting variables since my hand can stay with the mouse and mouse wheel, ctrl-shift-F7 is good enough for now :) I also liked the fact I can highlight 2+ different variables. I felt a lot more comfortable editing code now :)

0

Please sign in to leave a comment.