Missing files in Ctrl-Shift-N search

Answered

I don't know how it happened, but PHPStorm is suddenly only showing newly created files in the ctrl-shift-N search. I haven't been able to find comments anywhere about this being an issue and it's driving me nuts. The closest thing I can find to explain it is scopes, but I don't have any. Nothing is excluded either. I've tried deleting the project files (not the sources, but the .idea folder) and recreating it, but that didn't work. I opened a different project that I haven't touched in days and it's behaving the same way. I must have accidently hit a keystroke that broke it but I can't find any solution.

8 comments
Comment actions Permalink

Hi there,

First of all: please try "File | Invalidate caches..." and restart IDE.

Secondly: that popup window has filter icon -- click on it and make sure that ALL file types are checked (you can use "All" button for that)

15
Comment actions Permalink

Thank you SOOOO much. The Invalidate Caches fixed it. I'd been hammering at it for an hour. :)

1
Comment actions Permalink

@Andriy Bazanov  Thank my friend !  :)

0
Comment actions Permalink

Thank you for this... It worked for me (WS v2017.1) when I lost the ability to find files by name. 

0
Comment actions Permalink

Andriy Bazanov you beautiful, beautiful person (fixed the quick open in WS 2017.3)

I feel like I've regrown a missing appendage.

Dear Project nav and Trackpad,

I know you both enjoyed the unprecedented attention but I think we should go our seperate ways. It's better this way.

0
Comment actions Permalink

I love you Andryi,

your'e the hero we don't deserve

0
Comment actions Permalink

In my case, it was a problem with the .idea directory being tracked in git. Simply removing the folder and letting it regenerate fixed this issue for me and my colleagues.

And don't forget to add .idea to .gitignore :P 

1
Comment actions Permalink

Sam Goodger's solution mostly worked for me.  However, removing the .idea directory (located in the project root) ended up blowing away a number of other project-specific settings such as my Contexts and the project-level dictionary. 

I restored the old .idea/ and systematically removed-then-restored files from it until Ctrl-Shift-N worked again.  For me, it began working when I removed a file called 'Symfony2.xml' but it might be different for others.

0

Please sign in to leave a comment.