CVS over ssh

i just went thru the forum listings with the same problem. but mine seems a little different.

i'm working on linux.i use :ext: method to connect from IDEA(2.6).[:ext:@:/usr/local/cvsroot] i used ssh-keygen -t rsa and generated a public key which i posted on the server. i set the CVS_RSH=/usr/bin/ssh and i set the CVSROOT too. from a terminal i'm able to execute all my cvs commands without typing a password. but from IDEA, cvs doesnt seem to work. this is the output i get in the console /usr/bin/cvs status ]]>
cvs : connect to (]]>):2401 failed: Connection timed out

CVS command finished execution



port 2401 is disabled on our server. and i cant figure out how it gets this port value.

7 comments

yes i went thru it kesha, but .exe on linux?

0

In article <4298859.1044081436197.JavaMail.javamailuser@localhost>,
jiveadmin@jetbrains.com says...

i just went thru the forum listings with the same problem. but mine seems a little different.

i'm working on linux.i use :ext: method to connect from IDEA(2.6).[:ext:<name>@<server>:/usr/local/cvsroot]
i used ssh-keygen -t rsa and generated a public key which i posted on the server.
i set the CVS_RSH=/usr/bin/ssh and i set the CVSROOT too.

from a terminal i'm able to execute all my cvs commands without typing a password. but from IDEA, cvs doesnt seem to work. this is the output i get in the console


/usr/bin/cvs status <filename>
cvs : connect to <server name>(<server ip>):2401 failed: Connection timed out

CVS command finished execution



port 2401 is disabled on our server. and i cant figure out how it gets this port value.


2401 is the default cvs pserver port- obviously, IDEA doesn't know you
want to use the :ext: method. See http://www.intellij.com/docs/CVS.pdf.

- Danny

0

thanx Danny, i saw that too. but it doesnt say anything about setting it up.
it only asks to refer to ssh docs. which i went thru and did all the settings before

0

For what it's worth it also has a problem on OS X. It's not an OS X specific problem either. Also that plugin for windoes is there is because Windows is just plain lame when it comes to SSH... they talk about security but they don't make it easy to USE security tools.

Anyway, if anyone figures this out we Mac folks can also use this fix. I know that if you start IDEA up from the command line it works fine, when you have the CVS_RSH env var setup, but it's when you startup from the executable that things go nuts and it keeps asking for a password.

R

0

After reading replies in this thread I'm confused about what may be
happening. I run IJ build 688 on RH8 using CVS over SSH very
successfully. Command line, gui makes no difference in my config.

Have you looked at passphrase/no passphrase issues?

I can't elaborate at the moment but if you're interested, send me a note
back and I 'll go through my config tonight.



Ben wrote:

i just went thru the forum listings with the same problem. but mine seems a little different.

i'm working on linux.i use :ext: method to connect from IDEA(2.6).[:ext:<name>@<server>:/usr/local/cvsroot]
i used ssh-keygen -t rsa and generated a public key which i posted on the server.
i set the CVS_RSH=/usr/bin/ssh and i set the CVSROOT too.

from a terminal i'm able to execute all my cvs commands without typing a password. but from IDEA, cvs doesnt seem to work. this is the output i get in the console


/usr/bin/cvs status <filename>
cvs : connect to <server name>(<server ip>):2401 failed: Connection timed out

CVS command finished execution



port 2401 is disabled on our server. and i cant figure out how it gets this port value.


0

Ben wrote:

/usr/bin/cvs status <filename>
cvs : connect to <server name>(<server ip>):2401 failed: Connection timed out
CVS command finished execution
port 2401 is disabled on our server. and i cant figure out how it gets this port value.


Well, I don't have a solution (unfortunately), but port 2401 is the one
used by the 'normal' CVS pserver client/server protocol. In other words,
IDEA doesn't seem to be using the ':ext:' (in your case, SSH) way of
connecting to the server.

For what it's worth - I'm using :ext: / SSH successfully on Windows &
linux (using IDEA 3.0.1)

CU,
Edwin

0

Please sign in to leave a comment.