WebStorm autosaves scss file immediately

I don't have any file watcher configured but WebStorm keeps saving the scss file after just about every keystroke.  This would not be so bad except I have a gulp watcher that compiles those so it spews errors when the file is saved in the middle of typing a name.

Is there a way to disable that?  I saw a few similar questions but the problems there were caused by file watchers.  Other files (even .less files) don't have this issue.

2 comments
Comment actions Permalink

Such auto-saving can be caused either by a file watcher (if 'Immediate synchronization' is on) or by Live Edit (LiveEdit saves SASS files immediately to update a HTML page - see https://youtrack.jetbrains.com/issue/WEB-7093). I'm not aware of any other reasons for such problems. Does the problem persist if no debug session is run/Live Edit is disabled?

0
Comment actions Permalink

Thank you, it must have been the live edit, when I shut down web storm I got a warning about disconnecting from Chrome, and after restarting this rmoning it is no longer saving automatically!  I must have accidentally started it goofing around the UI.

0

Please sign in to leave a comment.