Compatibility

Is there any information about compatibility of the UI forms to prior versions of Idea available? Idea 4.5 can not load a form file of the latest 6.0RC. Ok - this might be obvious, but is there a general guideline about compatibility?

Regards
Thomas

1 comment

Hello Thomas,

TH> Is there any information about compatibility of the UI forms to
TH> prior versions of Idea available? Idea 4.5 can not load a form file
TH> of the latest 6.0RC. Ok - this might be obvious, but is there a
TH> general guideline about compatibility?

General guideline: forward-only compatibility. You must be able to edit older
version forms with a newer version, but you may not be able to edit newer
version forms with an older version.

(In fact, if you're really carefully avoiding the use of any new 6.0 features,
you may be able to open 6.0-designed forms in 5.x, but it's not guaranteed
and there are no features to help you ensure compatibility.)

--
Dmitry Jemerov
Software Developer
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.