Debugger problem

Hi,

I am using intellij 5.0 with jdk 1.5.
I'm starting the debugger (both in socket and shared memory mode) to debug a class from within intellij, and it completely ignores my breakpoints and runs the application.
On the intellij console I see that the debugger started and was attached properly.
I also tried attaching to the remote java application (again both shmem and socket), but got the same behavior, the breakpoints get ignored altogether.
When the application is running, The breakpoints that should have stopped get the x mark on them, saying "Source code changed" although it didnt.

I worked with the debugger and intellij before and had no such problems.
(By the way, debugging info is on, tried with and without force classic vm option, I also turned off compilation before debugging just to be on the safe side)

I'd appreciate any idea.

Thanks,
Asher

2 comments

did you get any resolution on this ?

I am facing the same exact problem.

TIA for any info

0

Hello,

I have a similar problem that remote debugging no longer works. I figured out that my Mac has been updated to Java 1.5 at some point, which might be the problem! Sun changed the options to invoke remote debugging so that the ones suggested in the IntelliJ Debug Configuration window cannot be any longer copied and pasted to the commandline invoking your Java application...

When forcing my Mac back into Java 1.4.2, the debugging worked again.

Still trying to configure it for Java 1.5 though.
-Linda

0

Please sign in to leave a comment.