Sun Applicagtion Server 9 PE Support

Couple of questions. I heard a rumor that this will be supported with an
upcoming plug-in to 6.0 to be released in the future. Is this true?

Also, I have been trying to configure this on my own using the "JSR 45
Compatible Server" configuration. Is this a waste of my time? Has anyone
done this successfully? So far I have things starting/stopping the
domain in the Run configuration. When I attempt to use the debug
configuration the console output show that it is starting the domain in
debug mode but it hangs part way through the start up. Starting the
appserver by hand in debug mode using the same command line which is in
the Startup/Connection configuration does put the appserver in debug
mode, but using IDEA does not (it hangs). So I thought perhaps I could
start the appserver in debug mode by hand and then just 'attach' idea
but the JSR45 configuration insists that a Port be specified and since
the appserver is already running it complains that the port is in use.
Any thoughts on this approach? Thanks,

-Noah

2 comments

I'd also be very happy about glassfish/Sun JSAS support, would be really
great. I like this server very much, its cool for deployment/production
but I think its real strength (advantage) compared to the (few) other
JEE 5 servers is using it in development - thus integration into IDEA
would really be great.

regards,

Messi

P.S@Noah: Sorry but haven't even tried to configure it as JSR45 server,
I'm using command-line JPDA

NBW wrote:

Couple of questions. I heard a rumor that this will be supported with an
upcoming plug-in to 6.0 to be released in the future. Is this true?

Also, I have been trying to configure this on my own using the "JSR 45
Compatible Server" configuration. Is this a waste of my time? Has anyone
done this successfully? So far I have things starting/stopping the
domain in the Run configuration. When I attempt to use the debug
configuration the console output show that it is starting the domain in
debug mode but it hangs part way through the start up. Starting the
appserver by hand in debug mode using the same command line which is in
the Startup/Connection configuration does put the appserver in debug
mode, but using IDEA does not (it hangs). So I thought perhaps I could
start the appserver in debug mode by hand and then just 'attach' idea
but the JSR45 configuration insists that a Port be specified and since
the appserver is already running it complains that the port is in use.
Any thoughts on this approach? Thanks,

-Noah

0

Please sign in to leave a comment.