Deployment Options greyed out - Project files not loading from remote

I just created a brand new Symfony project on an Ubuntu server in VMWare Player. I downloaded them with Filezilla to my drive. I then created new project from local, with no server in PHPStorm. (I couldn't get the server option to work -- kept getting a 500 error - but this is how I've done it in the past so I know it works this way)

Problem is that I have no deployment options available. They are all greyed out. I also notice that my 'Project Files' have a loading spinner, but when I click 'Project' they show up just fine. (Update: I started from scratch, project files now load fine, still no deployment options)

Not sure what I'm missing. Remote Host viewing works for my mappings. Just no deployment.

4 comments
Comment actions Permalink

Hi there,

Not sure what I'm missing. Remote Host viewing works for my mappings. Just no deployment.

So ... are you able to download from remote or not?

Please show your Deployment configuration (all tabs)

0
Comment actions Permalink

Update: My deployment path was not specified -- was left blank. The thing I don't get is this is how I've done it in the past and it has worked fine. What should my settings be? In the past I had mappings setup as

Local Path: C:\Desktop\project
Deployment path: (blank) <--not actually typed, just blank
Web Path: /

I have them setup as slashes now and it's working. Do we need to have these setup both as slashes? I thought these were to be left blank from a Maarten video I had seen, and my old ones work with it set that way.... You get a warning the says 'Deployment path is not specified', but it always worked.

Odd, anyway, it's working now so I'll stop thinking about it.

1
Comment actions Permalink
Do we need to have these setup both as slashes?

It depends on how your FTP users (FTP server) are configured.

Your blank field -- this is a folder that IDE/FTP client will change after sucessfully loggin into remote host.

In most cases (if all configured correctly) it indeed will be just a "/".

0
Comment actions Permalink

This is a super old thread but I was able to solve this in 2017.1.

I wanted to edit files on a remote server so I used "Create new project from existing files..." and then selected files on remote host.

by:

 

  • going through the process including setting up new FTP server
  • get to greyed out portion to add a project root
  • hit cancel
  • do it a second time
  • now you can select the FTP server that you set up the first time
  • when you hit continue, project folder is no longer greyed out

 

This is a workaround, but it worked for me.

After you set up your folder PHPStorm will download a copy of the remote files to your local machine so be sure that you have drive space available.

0

Please sign in to leave a comment.