java-Toplevel-Package (java.lang.String) not found (Mac OS X)

Hi !
I'm trying out IDEA 3.0 (build 686) on Mac OSX 10.2.2 with DP6. I'm starting IDEA from the terminal with a direct call to java. I've added the "-cp"-Paramter to set the Classpath according to the install.txt-File, so that the idea.jar, jdom.jar and log4j.jar are found.

This seem to work since IDEA starts up. However, my big Problem is: IDEA marks all Classnames from the java-Toplevel-Package as unknown (e.g. java.lang.String or java.io.File).
I'm quite sure, that it is a problem with my classpath and not a IDEA-Bug. I've checked developer.apple.com and other sources but I couldn't figure out, what is wrong.

Has anyone had the same problem or any idea how to fix this ?

Thanks in advance,
Christian

2 comments
Comment actions Permalink

Seems you haven't configured JDK for your project properly. Go to Project
Properties and click "..." browse button near Target JDK label.

--

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Christian Schwanke" <jiveadmin@jetbrains.com> wrote in message
news:4442810.1039188947726.JavaMail.jrun@is.intellij.net...

Hi !
I'm trying out IDEA 3.0 (build 686) on Mac OSX 10.2.2 with DP6. I'm

starting IDEA from the terminal with a direct call to java. I've added the
"-cp"-Paramter to set the Classpath according to the install.txt-File, so
that the idea.jar, jdom.jar and log4j.jar are found.
>

This seem to work since IDEA starts up. However, my big Problem is: IDEA

marks all Classnames from the java-Toplevel-Package as unknown (e.g.
java.lang.String or java.io.File).

I'm quite sure, that it is a problem with my classpath and not a IDEA-Bug.

I've checked developer.apple.com and other sources but I couldn't figure
out, what is wrong.
>

Has anyone had the same problem or any idea how to fix this ?

>

Thanks in advance,
Christian

>


0
Comment actions Permalink

Hi !
Thanks for your help - I've checked the settings.
There is currently only the JDK 1.4.1 configured.

I just had to add the "classes.jar" and the "ui.jar" manually to the Classpath-List.

Thanks again ,

Christian

0

Please sign in to leave a comment.