Cannot install package with Bower?

I am trying to install packages using Bower. I bring up the attached screen and I go through the screens to install jQuery and toastr. But, when I go back to the screen to see the packages installed I don't see them. Plus bower.json doesn't seem to be modified. I have attached the log file for these commands if it helps (it doesn't make much sense to me). Also here are the versions of the applicable programs that I am running:

>bower --version
1.3.12
>node --version
v0.10.35
>npm --version
1.4.28
>git --version
git version 1.9.5.msysgit.0

Thank you for any suggestions.

Kevin



Attachment(s):
idea.log.zip
36 comments

1) C:\Users\Kevin\AppData\Roaming\npm\node.exe --version
v0.8.18
Which is interesting because in the same directory running node --version
v0.11.16

...

Also what do you thing is up with the different node versions? Or do you think that is part of the problem?
I also found a node.exe in "C:\Program Files (x86)\Microsoft SDKs\Azure\CLI\bin\node.exe" This node reports
"C:\Program Files (x86)\Microsoft SDKs\Azure\CLI\bin\node.exe" --version
v0.10.23
So having just one node version would be nice?

Having multiple node versions is OK as long as things are predictable. As I said, I guess "C:\Users\Kevin\AppData\Roaming\npm\node.exe" is used when running "bower install jquery --save" command.
You can verify that in this way:
1. Edit file "C:/Users/Kevin/AppData/Roaming/npm/node_modules/bower/bin/bower"
2. At the top of the file add line "console.log(process.execPath);" after 'use strict' statement
3. Run "bower --version" in console. It shoud output path to node in the first line and bower version in the second. What node path is output?

You can also check the output of "where node" command to figure out which node.exe files are in PATH.

Basically all of the commands seemed to work. It has the feeling of a cache issue because I know it failed. And as soon as I declare it working I am afraid that it will revert back.

To eliminate cache issue execute you need to clean state:
1. Change directory to "install-bower-package/"
2. bower uninstall jquery --save
3. bower cache clean
Then repeat 2-5 steps from my previous post. What are the results?

0

As you said bower --version with the change to output the node path outputs

C:\Users\Kevin\AppData\Roaming\npm\node.exe
1.3.12

Also "where node" outputs

C:\Program Files\nodejs\node.exe => v0.11.6
C:\Users\Kevin\AppData\Roaming\npm\node.exe => v0.8.18


Two paths ? I would like to eliminate the old version so that the one in "Roaming" is the latest version. Is that as simple as copying the .exe? But what about the node_modules? There is also an npm file and an npm.cmd as well as a bower and bower.cmd. I am not sure why this didn't get updated when I installed a new node.js (the one from C:\Program Files\nodejs?

Thank you for you help. It is my feeling that if I can get what is Roaming up to the latest version my problem may be solved. Yes?

Thanks again.


0

Thanks for the information.
Honestly, I don't know why node.exe is installed in "C:\Users\Kevin\AppData\Roaming\npm". On my machine I have only "C:\Program Files\nodejs\node.exe".
You may consider uninstalling all Node.js versions. Then, if "C:\Users\Kevin\AppData\Roaming\npm\node.exe" still exists, delete it manually.
After that install needed Node.js version.

0

OK I think you can close this everything seems to work now that I have only one version of node. Thank you for sticking with me.

One question completely off the subject. In WebStorm I notice that some of the file names (in the project view on the left) are red. What does this mean?

Thanks again.

Kevin

0

Great! Glad it works now.
About red file names in Project View: there can be different reasons, like:
* a file contains errors
* during the last update, file was merged with conflicts (https://www.jetbrains.com/idea/help/file-status-highlights.html)
A screenshot is required to identify the cause more accurately.

0

From the link you showed me it seemed like it was "brown" and not red. I added it to the Git repository and it is no longer brown. Thanks again.

webstormfile.jpg

0

Please sign in to leave a comment.