Problems with my phpStorm

Hello,
I have some strange problems with my phpStorm.
First autocompletition for bootstrap doesn't work and it is very annoying.
Second I have a problem with the link for css like in a scree shot and I would like to fix it because is not working propeply.
How you see that have strange colors and I would like to back to the normal one.
Screen Shot 2015-02-09 at 10.50.48.png
Thanks for help
Jakub

11 comments
Comment actions Permalink

Hi there,

Second I have a problem with the link for css like in a scree shot and I would like to fix it because is not working propeply.
How you see that have strange colors and I would like to back to the normal one.

Place caret there on error marker and press Alt+Enter -- show a screenshot of context menu that will appear.

Quite likely you have custom/wrong language injected into "href" attribute. If that's the case then you should go to "Settings (Preferences on Mac) | Editor | Language Injections" and find and disable (or even delete) offensive rule there -- it will have "IDE" or "Project" value in last column.

0
Comment actions Permalink

Hi,
That works but I still have no autocompletition for bootstrap.

0
Comment actions Permalink
but I still have no autocompletition for bootstrap.

You have not provided any info at all about your setup etc .. and I left my remote mind reading device at home to change .. so cannot see what you have got there.

Therefore only general suggestions:
1) "File | Invalidate Caches..." and restart IDE
2) Do you have actual bootstrap's .css files in your project? IDE will not magically get code completion if it is not referenced in the project settings (e.g. files as part of the actual project) -- having just a link to external resource (like you have) is not enough.
If you do not, then either:
  a) download and place such file anywhere in the project -- so that IDE can index and analyse it
  b) Alt+Enter on such external link and choose "Fetch" (or whatever that option is called) to download external resource to your computer for IDE to analyse it.

0
Comment actions Permalink

I did the 1) "File | Invalidate Caches..." and restart IDE and the alt + enter for download to the cache but still nothing. It Is wired because works until today and I don't understand why now not.
I also tried to put the css without the cdn thing but is the same.

0
Comment actions Permalink

First of all: anything interesting in idea.log (Help | Show Log in ...)?

Any plugin updates or project settings changes done recently etc? If so -- try disabling 3rd party plugins to see if  htis will do any better.

-----

I've just tried with the same version as you have (brand new empty project with just single HTML file and .css) and it seems working just fine here (note that it's an empty project so it's hard to mess up with other code in it).

I suggest trying the same -- band new empty project -- to see if it works at all.

-----

You can always try this:
a) backup and delete your project settings (.idea subfolder) while project is closed in IDE, of course
b) Open folder in IDE -- it will open it as brand new project with no previous config -- see it will do any better (in case if some project settings affecting this)
NOTE: you can always restore your old settings from backup -- be it full settings or only parts of it

0
Comment actions Permalink

Still no autocompletition with a new project. In the log file I didn't find nothing interesting. Maybe I have to reinstall the editor?? Very strange because worked and I don't rmember any update.
What can I do? I tried again with the cache thing and maybe there is a way to reset the settings in some way??

0
Comment actions Permalink

Yes -- you may try with deleting IDE config and reinstalling it from scratch

1) Backup and Delete current settings: https://intellij-support.jetbrains.com/entries/23358108-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs

2) Uninstall IDE

3) Install PhpStorm again using latest version (8.0.2 is latest stable and 8.0.3 build #129.1226 is the latest on EAP channel)

0
Comment actions Permalink

Thanks I will try in this way. By the way I saw after the cache invalidate the alt+enter stop working. There is a way to fix it?? maybe could be this the problem??

0
Comment actions Permalink

Possibly. I do not know.

You have not provided any useful information to make any suggestions or any hints about what is actually happening there.

Attach your idea.log -- it may have some hints.

0
Comment actions Permalink

I attached my log file.



Attachment(s):
idea.log.zip
0
Comment actions Permalink

As you have said -- nothing interesting in it.

I may only suggest to try to disable all custom (not bundled) plugins and see if it will behave any better.

Other than that -- no ideas, sorry (except fresh reinstall with deleting all settings).

0

Please sign in to leave a comment.