Line separators

Hello

I have some GIT issues with separators but today I've come to other problem that could be cause of that. I've created brand new Composer project (no GIT) with laravel/laravel dev just to test Laravel 5. What I discovered all files have CLRF line endings instead of LF. Is there any setting in PhpStorm for that ? I've looked after downloading files and by default for new files I have Unix line separator. So why PhpStorm creates CRLF everywhere in that case?

4 comments
Comment actions Permalink

Hi there,

Any .ediorconfig files in the project? They have priority over IDE settings.

0
Comment actions Permalink

Nope, I don't have any. When creating project I've used as "Project type" - "Composer project", nothing more.

0
Comment actions Permalink

You mean -- files created by that "new composer project" action creates files with such line separators .. or files that you create AFTER project is created.

In first case it could be your git configuration (used by Composer).

Don't have any other ideas, unfortunately.

0
Comment actions Permalink

Thanks for reply. It's indeed not PhpStorm fault, the problem are tricky GIT settings on Windows machine.

0

Please sign in to leave a comment.