Please let me know when is coffee time .

After installing the newer version of intellij v5.1.2, i noticed that memory consumption does not consumed faster than v5.1. But then, I observe that at times, the pause becomes noticable sometimes as long as 2min. For example, when the memory about to reach certain threshold like 99/104 meg, suddenly intellij freeze for garbage collection for as long as 2 min. After 2 min, it becomes 70meg ram instead.

This is a good improvement but please let me know when to take coffee break in advance. The pause is simply too long and unpredictable. Luckily this editor is not used to fly airplane. Most will die of heart-attack.

Unfortunately, today, this is what happened, I show a demo of intellij to a VP, and guess what after opening several file and compiling, the GC kick in, and the VP stare at me for few minutes while I entertain him verbally.

I guess this is not the most intelligent thing to do...

peee... .here goes my career <:^{

2 comments
Comment actions Permalink

I have been dealing with 2+ min GC times since I first started to use IntelliJ back in the 4.x days.

Jetbrains doesn't seem interested in fixing this. Apparently we just have to live with it or switch to Eclipse.

These options in your idea.exe.vmoptions (in ]]>/bin) have helped the situation for me somewhat:

-Xms64m
-Xmx256m
-XX:MaxPermSize=92m
-ea
-server
-Dsun.awt.keepWorkingSetOnMinimize=true

(the keepWorkingSetOnMinimize is a workaround for a swapping bug in windows, if you aren't on windows you don't need it...makes intellij not take forever to respond after being minimized for a long time...this will work for any java app running under 1.5)

0
Comment actions Permalink

thank for your settings. Will try it once I finished my coffee break .. <:^]

0

Please sign in to leave a comment.