Unable to drag navigation tabs

Answered

For some reason, I am now no longer able to drag the file tabs in the editor window to a different position, or to drag them to another screen to popen a new editor window.

I've tried poking around preferences to see if there's some setting I experimentally changed, but so far no luck.

Does anyone have any idea on what is causing this?

Thanks heaps.

Paul

14 comments

Hi there,

For some reason, I am now no longer able to drag the file tabs in the editor window to a different position,

Possibly "Sort Tabs By Filename" is enabled (check editor tab's context menu) ?

or to drag them to another screen to popen a new editor window.

The aforementioned option, even if it's enabled, does not affect dragging editor tab out of the IDE window and opening new detached editor.

Does anyone have any idea on what is causing this?


Other than that I may suggest

1) Check your idea.log file for any possible hints (exceptions) -- "Help | Show Log in ..."

2) Try disabling all 3rd party plugins and try again (just in case)

If nothing: backup and delete (plus use "File | Export Settings...") your IDE settings and start from fresh -- you may then re-import almost all of your settings back. If it's called by some setting then you may loose only one of the setting config files (although it still needs to be found; if this is a special setting at all).

0

I have the same problem, and I just submitted a support ticket about it. I looked in my idea.log, but I have no clue about what to look for. The word "exception" does not exist in the log. I wouldn't recognize an issue if it were screaming at me.

I have not deliberately installed any 3rd party plugins, and I have no idea how I would know if any came as part of the PHPStorm packaged.

I have exported my settings, but I have no clue how I would incrementally restore them to resolve the problem. Finder offers to let me open settings.jar with 'Jar Launcher.app' but that utility cannot be launched: The Java JAR file "settings.jar" could not be launched.

I will continue to await the response from my support ticket.

0

Go to file-> Import Settings, Ken, and select the export file. It should ask you what settings you want to re-import.

0

Right you are! Thanks.

I have looked in vain for a way to reset all the settings to out-of-the-box values. There are 'default settings', but those seem to be the values that apply only to individual projects and not the IDE as a whole, and they are only used when a new project is created. I could delete my settings.jar file and hope that PHPStorm will create a new one with default settings without destroying my project definitions, but I don't think I'm that adventurous.

So...is there a way to have PHPStorm reset all the settings to the factory values? I presume that project definitions would be reset too, right? Once reset, I could create a project and (1) see if dragging/dropping editor tabs works, and if so (1) progressively import settings until it stops working. This is going to take a long time.

0

@Ken

There is no "Reset" button. You will have to delete config files manually. Please refer to the document below to find out where they stored (on Mac OS it will be few locations). But back up them first (just in case; plus, some of them you should be able to re-use with no issues (custom templates; keymap; syntax colors etc)).

https://intellij-support.jetbrains.com/hc/en-us/articles/206544519-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs

After you delete IDE-wide settings (while IDE is closed, of course) IDE will start with defaults on next launch (well, it should ask you what to do -- e.g. import preferences from previous version etc).

Any project-specific settings will remain unchanged (as they are stored together with the actual project in .idea subfolder). You will have to just use "Open" and point to the project root -- IDE will re-open existing project from there.

0

OK, I will try what you have suggested.

My goal is to have the functionality illustrated here: https://www.youtube.com/watch?v=h2kZxeU524o.

0

Andriy, thanks for your help.

OK, I am at /Users/<USER>/.Library/Preferences/Webide100. There are 229 files/folders there, amounting to 2Mb of settings info, not counting the separate folders for Caches, Plugins and Logs. Are you saying that I should delete EVERYTHING under these folders and then bring them back piecemeal, testing for drag/drop operation at each step?

This back-and-forth process is like my mother trying to play a movie on her TV from a DVD. She has no clue what she's doing, and she's just randomly pushing buttons until she stumbles across something that seems to work. She doesn't care how long it takes, because she has nothing else to do. I am a software engineer who understands complex things, but I have very little background in the bowels of PHPStorm and don't have days of idle time to try this and try that with day-long forum/ticket interactions between every step. I realize that debugging my situation may take some work, and I am willing to do it, but I simply need more efficient guidance.

When I first transitioned from Zend Studio to PHPStorm last year (a move I made because after months of round-robin support ticket traffic, I simply could not get Zend to address a blocking issue), I had an early critical problem with debugging. After a bit of back-and-forth on a support ticket, a JetBrains support tech phoned me, shared my screen and the problem was fixed in 15 minutes. This feels like another one of those times. Can I ask for that here or should I ask via the support ticket I have open (https://intellij-support.jetbrains.com/hc/en-us/requests/675339)?

0

Better ask for such interactive help (via TeamViewer etc) in support ticket that you have opened. So far there were no JetBrains stuff participating in this thread.

>Are you saying that I should delete EVERYTHING under these folders

Yes. At very least you will see if it helps or not. If no changes -- restore from backup as it would be not an issue with IDE setting.

Stuff in Caches and Logs can be delete permanently (no real need to back up) -- they will be regenerated from scratch anyway (e.g. it's done when you use "File | Invalidate Caches" or when updating to a next major version)

My idea is:

  • 1) Backup and delete stuff to see if it helped
  • 2.1) If it did not -- just restore everything back -- issue is not IDE settings but maybe with actual OS settings or Java version used
  • 2.2) If it did -- restore whole stuff from Preferences folder only (delete everything once again and restore Preferences only)
  • 3) If it still works -- reinstall plugins one by one from within IDE
  • 4) If it works fine with brand new setup but does not after 2.2 .. then delete everything again and obtain default settings (launch IDE at least once). Then recover most safest settings from backup copy (I'm not sure how exactly it is there on Mac, but here on Windows I would restore stuff from these sub folders: codestyles, colors, fileTemplates, filetypes, inspection, keymaps, templates, tools -- would definitely not touch stuff in "options" subfolder)

These steps should take you under 20-30 mins -- and you will know if it will work or not.

BTW -- consider trying latest 2016.1 version (2016.1.1 EAP build, as it contains fixes for issues found in 2016.1) -- maybe it will work better (it can run in parallel to your current version -- just do not import any settings on first launch).

0

OK, thanks for the details. I did indeed ask for screen-sharing help via my ticket, but I will try your latest steps while waiting on a reponse. I really do need to upgrade to 2016.1.1, and maybe that would be a simpler way to refresh whatever is broken. I will renew my subscription as well, as it will run out in May 2016.

0

Andriy, I decided to take the shortest path first. I renamed my v10 PHPStorm.app and downloaded/installed v2016.1. It came up, asking for my license key. I provided that, then I instructed it to import the settings from my v10 installation. Everything came up normally on my current project, but dragging/dropping editor tabs still did not work.

Next, I blew away ~/Library/Preferences/PHPStorm2016.1 and restarted PHPStorm 2016.1. This time, I did NOT let it import settings. I then opened my current project via directory selection. Voila!, editor-tab drag/drop now works!

Now I will attempt to individually import groups of settings from the v10 installation to get back as much of my previous environment as possible. If at any point I lose editor-tab drag/drop, I know what was corrupted.

I suspect that I could have done the same process on v10 and had it work, but your suggestion now has me using the latest and greatest. I think I can take it from here, and I will close my ticket.

Thanks a million for your help!

0

Found the answer to this in case anyone is still looking - Settings > Appearance & Behavior > Appearance > Drag-n-Drop with ALT pressed only.

12

Mark, thanks for finding that. I have no idea how that got changed but in upgrading from 2017.1 to 2017.2 it apparently got set.

1

Cannot DnD

 

  • I checked the Drag-n-Drop ALT and that was not set.
  • click and drag "picks up" the tab, but it will not go into another spot. 
  • Drop on far left of tab bar and it floats back to where is started.
  • No Exceptions in the error log or any other logging while trying to move tabs.

Still searching for a solution.

0

https://www.jetbrains.com/help/pycharm/sorting-editor-tabs.html

I had to uncheck the alpha sorting, not sure how that got set....

To sort editor tabs alphabetically

  1. Right-click an editor tab.
  2. Select Sort Tabs by Filename.

    If this check command is selected, the tabs headers are presented in alphabetical order. Otherwise, the editor tab headers appear in the opening order of the corresponding files.

1

Please sign in to leave a comment.