xDebug > phpStorm ist listening on wrong IP-address

Hello,
I have change the server - IDE-Client situation. (I know, don't change a running system! But I have to...)

Before, Server and IDE was both on a OSX MacBookPro. All was running fine.

SITUATION NOW:

SERVER (MACBookPro OSX 10.7.5) FIX IP 192.168.178.100
with working xDebug
But xdebug_remote.log Entry :

Log opened at 2015-01-08 15:43:46
I: Connecting to configured address/port: 192.168.178.200:9000.
E: Time-out connecting to client. :-(
Log closed at 2015-01-08 15:43:46

PHPSTORM-IDE (8,02 on WIN8 Laptop in same LAN) FIX IP 192.168.178.200
I start debug-Listening with green phone but NO REAKTION IN IDE when I reload the site, or use the Bookmarklet ....

NETSTAT -a -n -o says:
Proto      Local                   Remote        State          PID
TCP      0.0.0.0:9000        0.0.0.0:0     Listening     4936 (phpStorm.exe)
TCP      0.0.0.0:10137      0.0.0.0:0     Listening     4936 (phpStorm.exe)
TCP      0.0.0.0:20080      0.0.0.0:0     Listening     4936 (phpStorm.exe)
TCP      127.0.0.1:6942    0.0.0.0:0     Listening     4936 (phpStorm.exe)
TCP      127.0.0.1:52414  0.0.0.0:0     Listening     4936 (phpStorm.exe)
TCP      127.0.0.1:52415  0.0.0.0:0     Listening     4936 (phpStorm.exe)
TCP      127.0.0.1:63342  0.0.0.0:0     Listening     4936 (phpStorm.exe)
TCP      192.168.178.200:51480  192.168.178.100:80     Close_Wait    4936 (phpStorm.exe)

---> I think the Problem is : IDE should listen on 192.168.178.200:9000 but this is missing.
I looked everywhere. In Preferences, in google and the jetBrain Docs but nowhere is written how can I change the Listening IP from 0.0.0.0:9000 TO 192.168.178.200:9000. Maybe I'm wrong. Have someone a solution for my problem. Maybe I missunderstud something with the IP's in netstat.

I would love to see:
TCP      192.168.178.200:9000  192.168.178.100:(whatever)     LISTENING    4936 (phpStorm.exe)


[MORE DETAILS]
Preferences in phpStorm:
Languages & Frameworks > PHP > Debug > Xdebug
Debug port: 9000
Can accept external connections [TRUE]
Force break at first line when path ... [TRUE]
Force break at first line when outside ... [TRUE]

Build Execution, Deployment > Deployment > macBookProServer
Connection Type SFTP
SFTP host: 192.168.178.100
Port : 22
RootPath : /
User name / Auth type / Password: ****
Test SFTP connection ... is DONE AND OK
Web server root URL: > OPEN is the right website and is running OK

Run/Debug Configurations > PHP Remote Debug > OwnServerName
Configuration :
SERVER: MacBookPro
IDE-Key: phpStorm

php.ini
xdebug.remote_enable=on
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_host=192.168.178.200
xdebug.remote_port=9000
xdebug.idekey="phpStorm"
xdebug.remote_log="/opt/local/apache2/logs/xdebug_remote.log"
xdebug.remote_autostart=1

I did also a portforward in Router :  »Port 9000 To 192.168.178.200:9000«. Nothing changes.

I hope someone has an hint for me.
Kind regards
Martin

2 comments
Comment actions Permalink

Hi there,

I cannot speak about Mac (not a Mac user) .. but on Windows 0.0.0.0:9000 is enough. "0.0.0.0:9000" means that IDE listens on 9000 port on ALL interfaces.

I suggest to double/triple check your connectivity: maybe there is firewall somewhere between your computer with PhpStorm and the server one.).

To check your connectivity: on your server .. try connecting to your computer via telnet (to some another port first, not handled by PhpStorm).

P.S.
You can use online checker services to see if your port is properly forwarded/opened in firewall to the rest of the world (that's if your server is a remote one -- somewhere on Internet and not local LAN or VM). That's especially important when you need to do port forwarding in your hardware router.

For example:


P.P.S.
You can always try to connect via SSH to bypass possible firewalls (as it's an xdebug which connects to PhpStorm and not other way around). For example:

0
Comment actions Permalink

Hey Andriy,
again you are the candle-man in a stormy night.
The "0.0.0.0" blinded me for the obvious. Newby on micro$soft :O (for a while - maybe). Thank you for the light!
Now I can see the idea behind four-zero-ip.
Without blindfould, the redwall jelled to me: Are you stupid? I'am your target ...
Yes, with a simple rule for port:9000 in the firewall it was done. Stupid I know.
But thanks to the four-zero-ip-blindfould, I learned a lot in xDebug, logging, server-config, portforwarding, phpstorm and the preferences, and not at least windows.
It runs, also without portforwarding.
Thanks to you and your help and : Apologize!

Kind regards
Martin

0

Please sign in to leave a comment.