Ant shortcut

I can't assign shortcuts to my ant targets. The Assign shortcut is disabled. Do anybody know why?

6 comments
Comment actions Permalink

You have to copy the existing keymap. Now, you can assign shortcuts in your copy of keymap (don't forget to activate the copy), e.g. ant targets

- Christian

0
Comment actions Permalink

I have already copied the keymap and changed some shortcuts, and newly assigned shortcuts works fine.

The problem is that the "ant targets" folder in the keymap dialog remains empty and the "assign shortcut" option in the ant windows is disabled.

I have tryed to create all the configuration stuff form scratch and it doesn't work.

0
Comment actions Permalink

I saw this problem myself, and I'm happy to report its easy to get around.

As it turns out (and I'm not sure if this is a bug or a feature) you can't assign keyboard shortcuts to "filtered" ant targets. I'm not sure how the default filters get set up, but I suspect that the tasks with no description are by default "unchecked".

So, first you'll need to click on the "Ant Build" thingamajig so you can view your Ant targets. Next, right click anywhere in the window and pick "properties". Go to the "Filter Targets" tab and make sure the targets you are trying to assign a shortcut to are checked. Hit OK, and now right-click on the target you just checked and "Assign shortcut" should now be an option.

Good luck!

0
Comment actions Permalink

I had already unfiltered the ant targets.

Other options??

0
Comment actions Permalink

Hi Daniel,

you have to activate the filter on those targets you want to assign
shortcuts to, not 'unfilter'...

GreetinX,

Ren?

--
There are only 10 kinds of people in the world -
those who understand binary and those who don't.


"Daniel" <dlebrero@softhome.net> schrieb im Newsbeitrag
news:6398996.1037274555905.JavaMail.jrun@is.intellij.net...

I had already unfiltered the ant targets.

>

Other options??



0
Comment actions Permalink

I have found it.

In the ant file you must put the name attribute in the proyect tag. XD. Thx to all

0

Please sign in to leave a comment.