System Compatibility

Ok-- there's a high likelihood I'll be upgrading hardware soon, and I'm
actively considering Apple w/Mac OS X.

Looking over the 3.0 system requirements, I only see mention of Intel
platforms. Getting into the "way back machine" I seem to remember the
JetBrains guys saying that they would have 3.0 back ported to Mac OS X
before the release of 3.0-- so...

I'm curious as to whether or not IDEA 3.0 does or does not work on Mac OS X
or not.

Anyone have any clue?

Thanks!

rob.


4 comments
Comment actions Permalink

In short, you can start IDEA 3.0 up under OS X using Java 2 SDK 1.4.1 dp2 or dp5, but as far as usability is concerned, it is abysmal. Java 1.4.1 under OS X is far from feature complete. There are numerous UI issues and things like Ant are non-functional.

You can check this thread http://www.intellij.net/forums/thread.jsp?forum=22&thread=16784&tstart=0&trange=15

as there is a bug in the Tracker for you to vote for OS X support for IDEA 3.0.

For those JetBrains folks reading this, you're probably guaranteed to have at least 10-15 people who would gladly test IDEA 3.0 under OS X using 1.3.1.

0
Comment actions Permalink

On Tue, 12 Nov 2002 19:03:21 +0000, Robert Hedin wrote:

I'm curious as to whether or not IDEA 3.0 does or does not work on Mac OS X or
not.


I'm guessing OS/X isn't listed yet as IDE 3.0 requires Java 1.4, which isn't
publically available on OS/X yet ( theres a developer edition thou
apparantly?) - Maybe after its officially out for OS/X they'll 'support' it.

--

-- \m/ --
"...if I seem super human I have been misunderstood." (c) Dream Theater
mark@talios.com - ICQ: 1934853 JID: talios@myjabber.net

0
Comment actions Permalink

If they are still planning to back-port to 1.3.1,
it will be out as a separate release, as they
would not have had time for it yet.

Mark Derricutt wrote:

On Tue, 12 Nov 2002 19:03:21 +0000, Robert Hedin wrote:

>>I'm curious as to whether or not IDEA 3.0 does or does not work on Mac OS X or
>>not.


I'm guessing OS/X isn't listed yet as IDE 3.0 requires Java 1.4, which isn't
publically available on OS/X yet ( theres a developer edition thou
apparantly?) - Maybe after its officially out for OS/X they'll 'support' it.



--

Erb

==============================================================
"The only time I like in the morning is afternoon."
- Russell D. Cooper

"If you do everything, then you're all done."
- Melissa F. Cooper

"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

0
Comment actions Permalink

I was afraid of that-- thanks for the info, I'll check it out as I'm really
leaning towards the machine.

rob.

"David Czarnecki" <czarnecki@crd.ge.com> wrote in message
news:1077854.1037274560062.JavaMail.jrun@is.intellij.net...

In short, you can start IDEA 3.0 up under OS X using Java 2 SDK 1.4.1 dp2

or dp5, but as far as usability is concerned, it is abysmal. Java 1.4.1
under OS X is far from feature complete. There are numerous UI issues and
things like Ant are non-functional.
>

You can check this thread

http://www.intellij.net/forums/thread.jsp?forum=22&thread=16784&tstart=0&tra
nge=15
>

as there is a bug in the Tracker for you to vote for OS X support for IDEA

3.0.
>

For those JetBrains folks reading this, you're probably guaranteed to have

at least 10-15 people who would gladly test IDEA 3.0 under OS X using 1.3.1.


0

Please sign in to leave a comment.