Webstorm: Typescript Editor shows error when TSC does not

I am using Gulp for typescript compilation, which compiles fine but I get errors in the editor for various type conversion issues. I am assuming that either the Webstorm typescript compiler is out of date or there is an issue with Webstorm resolving files that Gulp is able to (though, there's nothing to indicate an issue with file resolution).

Is there a way to verify or update the version of typescript being used in the editor errors?

If not, then is there a way to either:
a) ...disable error detection in the editor for TS files?
b) ...use Gulp output for errors in files?

Edit:
Repro at https://github.com/jt000/RepoForWebstormTS

2 comments
Comment actions Permalink

It's a bug, logged as https://youtrack.jetbrains.com/issue/WEB-14760

Is there a way to verify or update the version of typescript being used in the editor errors?


No - as WebStorm uses its own parser for error highlighting/types resolving

a) ...disable error detection in the editor for TS files?


You can turn inspections/error highlighting off for current file using Hector  icon in the lower right corner: open your file in editor, click the  Hector icon and then move the slider to change the Highlighting level  to None See http://www.jetbrains.com/webstorm/webhelp/changing-highlighting-level-for-the-current-file.html

b) ...use Gulp output for errors in files?


not possiblw with Gulp, but possible with tsc compiler configured as a file watcher. When TypeScript file watcher is enabled, the errors highlighting from  WebStorm is suppressed and the highlighting from the compiler is used  instead

0
Comment actions Permalink

Thanks Elana.  I should've mentioned it before, but I had filed bug https://youtrack.jetbrains.com/issue/WEB-14748 as well (this post was just to find a workaround)

It is a bit unfortunate that Webstorm built its own typescript parser. Seems like it would always be a step behind the most recent version (plus since Typescript is open source, then this prevents people from using their own custom fork).

Thanks for the reference. I'll give removing the highlighting syntax a try...

1

Please sign in to leave a comment.