JSP Validation

I'm using IDEA 5.1.1 with the Sun Hotspot Client VM 1.5.0_06. I have a project with a web module with a number of JSPs in it. The Editor flags JSP errors within the editor window.

But a "make module" does not display any of these errors in the Make Errors window (only regular Java class errors are displayed)

I have "Run Jasper Validation for JSP files" checked and "Create web module exploded directory" checked under Module Settings | J2EE Building Settings.

Any ideas?

Sandeep

4 comments
Comment actions Permalink

Hello Sandeep,

Are you sure that the checkbox "Run Jasper Validator for JSP files" (Settings
| Modules | Your web module | "J2EE Build Settings" tab) is marked?

I'm using IDEA 5.1.1 with the Sun Hotspot Client VM 1.5.0_06. I have a
project with a web module with a number of JSPs in it. The Editor
flags JSP errors within the editor window.

But a "make module" does not display any of these errors in the Make
Errors window (only regular Java class errors are displayed)

Any ideas?

Sandeep

---
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

I had edited my question to reflect this. Here's my original post. I do have that checkbox checked.

-


>

I'm using IDEA 5.1.1 with the Sun Hotspot Client VM 1.5.0_06. I have a project with a web module with a number of JSPs in it. The Editor flags JSP errors within the editor window.

But a "make module" does not display any of these errors in the Make Errors window (only regular Java class errors are displayed)

I have "Run Jasper Validation for JSP files" checked and "Create web module exploded directory" checked under Module Settings | J2EE Building Settings.

Any ideas?

Sandeep

0
Comment actions Permalink

I have the same problem - some error lines are displayed in the compile
window, but not the associated files.
Try starting Idea with a console and looking at stderr/stdout.
R

0
Comment actions Permalink

Hello Sandeep,

Please run IDEA using idea.bat file and see that will be printed in console
after validation.

I had edited my question to reflect this. Here's my original post. I
do have that checkbox checked.

------->

I'm using IDEA 5.1.1 with the Sun Hotspot Client VM 1.5.0_06. I have a
project with a web module with a number of JSPs in it. The Editor
flags JSP errors within the editor window.

But a "make module" does not display any of these errors in the Make
Errors window (only regular Java class errors are displayed)

I have "Run Jasper Validation for JSP files" checked and "Create web
module exploded directory" checked under Module Settings | J2EE
Building Settings.

Any ideas?

Sandeep

---
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Please sign in to leave a comment.