Build 670 NPE

11757] ERROR - intellij.plugins.PluginManager -
11757] ERROR - intellij.plugins.PluginManager - JDK: 1.4.1_01
11757] ERROR - intellij.plugins.PluginManager - VM: Java HotSpot(TM) Client
M
11757] ERROR - intellij.plugins.PluginManager - Vendor: Sun Microsystems Inc

11757] ERROR - intellij.plugins.PluginManager - OS: Windows XP
11767] ERROR - intellij.plugins.PluginManager -
ava.lang.NullPointerException
at com.intellij.ide.c.j.d(j.java:1)
at com.intellij.idea.l.run(l.java:2)
at java.lang.Thread.run(Unknown Source)

4 comments
Comment actions Permalink

8< --- snip -


11767] ERROR - intellij.plugins.PluginManager -
ava.lang.NullPointerException
at com.intellij.ide.c.j.d(j.java:1)
at com.intellij.idea.l.run(l.java:2)
at java.lang.Thread.run(Unknown Source)



I got this too... followed by a lot of this:
ERROR - ij.components.ComponentManager - ComponentSetup for component com.intellij.vcs.starteam.StarteamVcsAdapter already registered
ERROR - ij.components.ComponentManager - IntelliJ IDEA 3.0 Build #670
ERROR - ij.components.ComponentManager - JDK: 1.4.1_01
ERROR - ij.components.ComponentManager - VM: Java HotSpot(TM) Client VM
ERROR - ij.components.ComponentManager - Vendor: Sun Microsystems Inc.
ERROR - ij.components.ComponentManager - OS: Windows 2000
ERROR - ij.components.ComponentManager - Component class com.intellij.openapi.project.ProjectManager is being requested during its own initializing procedure
ERROR - ij.components.ComponentManager - IntelliJ IDEA 3.0 Build #670
ERROR - ij.components.ComponentManager - JDK: 1.4.1_01
ERROR - ij.components.ComponentManager - VM: Java HotSpot(TM) Client VM
ERROR - ij.components.ComponentManager - Vendor: Sun Microsystems Inc.
ERROR - ij.components.ComponentManager - OS: Windows 2000
ERROR - ij.components.ComponentManager - Component class com.intellij.openapi.actionSystem.ActionManager is being requested during its own initializing procedure
ERROR - ij.components.ComponentManager - IntelliJ IDEA 3.0 Build #670
ERROR - ij.components.ComponentManager - JDK: 1.4.1_01
ERROR - ij.components.ComponentManager - VM: Java HotSpot(TM) Client VM
ERROR - ij.components.ComponentManager - Vendor: Sun Microsystems Inc.
ERROR - ij.components.ComponentManager - OS: Windows 2000
ERROR - ij.components.ComponentManager - Component class com.intellij.openapi.actionSystem.ActionManager is being requested during its own initializing procedure
ERROR - ij.components.ComponentManager - IntelliJ IDEA 3.0 Build #670
ERROR - ij.components.ComponentManager - JDK: 1.4.1_01
ERROR - ij.components.ComponentManager - VM: Java HotSpot(TM) Client VM
ERROR - ij.components.ComponentManager - Vendor: Sun Microsystems Inc.
ERROR - ij.components.ComponentManager - OS: Windows 2000
ERROR - ij.components.ComponentManager - Component class com.intellij.openapi.actionSystem.ActionManager is being requested during its own initializing procedure
ERROR - ij.components.ComponentManager - IntelliJ IDEA 3.0 Build #670
ERROR - ij.components.ComponentManager - JDK: 1.4.1_01
ERROR - ij.components.ComponentManager - VM: Java HotSpot(TM) Client VM
ERROR - ij.components.ComponentManager - Vendor: Sun Microsystems Inc.
ERROR - ij.components.ComponentManager - OS: Windows 2000
ERROR - ij.components.ComponentManager - Component class com.intellij.openapi.actionSystem.ActionManager is being requested during its own initializing procedure
ERROR - ij.components.ComponentManager - IntelliJ IDEA 3.0 Build #670
ERROR - ij.components.ComponentManager - JDK: 1.4.1_01
ERROR - ij.components.ComponentManager - VM: Java HotSpot(TM) Client VM
ERROR - ij.components.ComponentManager - Vendor: Sun Microsystems Inc.
ERROR - ij.components.ComponentManager - OS: Windows 2000
ERROR - ij.components.ComponentManager - Component class com.intellij.openapi.actionSystem.ActionManager is being requested during its own initializing procedure

0
Comment actions Permalink

Out of the box 670 install.
Copy intellij jre over into install dir
start
first lines of log file...

0
Comment actions Permalink

I just got this exact exception when starting build 671, and I can't run intellij at all. Has anyone found a fix for this? I guess I'll roll back to an earlier version :(

0
Comment actions Permalink

Scratch that, problem fixed. It was due to having old plugin jars installed in different directories, from installing the new zip over the old one.

0

Please sign in to leave a comment.