Single-click in the Project-tab opens the file, very annoying!

Hi,

Problem:
I would like to be able to single-click on a file in the Project-tab,
escpecially when right-clicking to get the right-click menu, WITHOUT
IntelliJ to open the file!
The same thing when I try to use the keyboard to scroll to the right file in
the Project-tab, IntelliJ opens each and every file on the way...before I
have actually selected the file I want to open.



Questions:
HOW can I stop IntelliJ from doing this?
Is there a setting somewhere?

Thank you in advance!

Regards,
/Jonas


2 comments

Hello Jonas,

The setting is "Autoscroll to source".

JL> Problem:
JL> I would like to be able to single-click on a file in the
JL> Project-tab,
JL> escpecially when right-clicking to get the right-click menu, WITHOUT
JL> IntelliJ to open the file!
JL> The same thing when I try to use the keyboard to scroll to the right
JL> file in
JL> the Project-tab, IntelliJ opens each and every file on the
JL> way...before I
JL> have actually selected the file I want to open.
JL> Questions:
JL> HOW can I stop IntelliJ from doing this?
JL> Is there a setting somewhere?
JL> Thank you in advance!

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Aha, I really like the "Autoscroll from source" feature, so I had
accidentally also selected the "to source"...

PS. It must have been a time record on your answer... DS.

Thank you Dmitry!

Regards,
/Jonas

"Dmitry Jemerov (JetBrains)" <yole@jetbrains.com> wrote in message
news:83ca25fd274c458c832938ed30120@news.intellij.net...

Hello Jonas,

>

The setting is "Autoscroll to source".

>

JL> Problem:
JL> I would like to be able to single-click on a file in the
JL> Project-tab,
JL> escpecially when right-clicking to get the right-click menu, WITHOUT
JL> IntelliJ to open the file!
JL> The same thing when I try to use the keyboard to scroll to the right
JL> file in
JL> the Project-tab, IntelliJ opens each and every file on the
JL> way...before I
JL> have actually selected the file I want to open.
JL> Questions:
JL> HOW can I stop IntelliJ from doing this?
JL> Is there a setting somewhere?
JL> Thank you in advance!

>

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

>



0

Please sign in to leave a comment.