Integrated ant build does not work when jar added in Additional Classpath

I am attempting to get the integrated Ant Build to work with one of my build.xml files. This file contains a weblogic specific ant task (wlappc). In IntelliJ 4.5, I could add the weblogic.jar as an Additional Classpath, and the build would work.

In Demetra 5218, however, when I do this it seems to break the Ant Build. When I execute the tasks in the build.xml, IntelliJ quickly responds that the build is complete, but it actually has not apparently run anything.

Is this a known bug?

Thanks,
ken clark

4 comments

Hello Ken,

I am attempting to get the integrated Ant Build to work with one of my
build.xml files. This file contains a weblogic specific ant task
(wlappc). In IntelliJ 4.5, I could add the weblogic.jar as an
Additional Classpath, and the build would work.

In Demetra 5218, however, when I do this it seems to break the Ant
Build. When I execute the tasks in the build.xml, IntelliJ quickly
responds that the build is complete, but it actually has not
apparently run anything.

Is this a known bug?


Yes, see here: http://www.jetbrains.net/jira/browse/IDEA-4317 .

--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Thanks!

Has anyone come up with a workaround so that wlappc, wldeploy, etc can be run from within IntelliJ? Do I need to configure IntelliJ to use the 1.5 version of ant (can I?) If so, how do I do that?

Thanks,
ken

0

Yes and yes.

In the Ant Build tool window, select the ant build file instance you want to use and then
.
On the Execution tab, select 'Use custom ant' and specify the ant version to use. If it is
not in the drop-down, use the '...' button to add it.
On the 'Additional Classpath' tab add the weblogic.jar file.

The wldeploy task now works fine for me.

0

This worked great.

Thanks for the help!

ken

0

Please sign in to leave a comment.