Remote Connection Mapping Appears Wrong

Using SFTP, when I try to rename a directory, I get this error message from the Remote Host window: failed to rename folder '/var/www/sitename_test/wp-content/plugins/mailchimp-for-wp' to '/var/www/sitename_test/wp-content/plugins/mailchimp-for-wp-hidden' could not rename 'sftp://97.XXX.XXX.XXX/wp-content/plugins/mailchimp-for-wp' because  sftp://97.XXX.XXX.XXX/wp-content/plugins' is read-only.

It appears my remote connection mapping is wrong. The directory mapped to is not at sftp://97.XXX.XXX.XXX/wp-content/plugins, it is sftp://97.XXX.XXX.XXX/var/www/sitename_test/wp-content/plugins. See the attached screen grab of my settings.

I tried deleting the connection and creating it anew, but still the same problem.

I can rename that same directory using a different FTP client, but not PhpStorm.

Am I doing something wrong? Any ideas why this is not working?



Attachment(s):
deployment-settings.png
2 comments
Comment actions Permalink

Please enable deployment log level, reproduce the issue and provide the log: http://devnet.jetbrains.com/docs/DOC-1202

0
Comment actions Permalink

Please see the attached log.



Attachment(s):
idea.log.zip
0

Please sign in to leave a comment.