Subversion folder (_svn) should not display in Project pane

I try to integrate Subversion with IDEA v5.1 and Demetra 5175 but when I check out project from Subversion, in Project pane it still shows _svn folder. I think it should be hidden, same as CVS folder in CVS.



Attachment(s):
svn.jpg
5 comments

t800t8 wrote:

I try to integrate Subversion with IDEA v5.1 and Demetra 5175 but when I check out project from Subversion, in Project pane it still shows _svn folder. I think it should be hidden, same as CVS folder in CVS.


Note that the correct name for this folder is ".svn", and it is hidden
properly by IDEA.

If i recall correctly, "_svn" is a workaround some people use for some
Microsoft product which couldn't handle dots in directory names.

Kreiger



Attachment(s):
signature.asc
0

I don't think so. 'Cause in Modules dialog, at Paths tab, IDEA doesn't show these folders (_svn). I think it's a bug in Windows version.

0

Hello t800t8,

Go to Settings|General and add whatever pattern to exluded files and folders
list.

-


Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I don't think so. 'Cause in Modules dialog, at Paths tab, IDEA doesn't
show these folders (_svn). I think it's a bug in Windows version.



0

Christoffer "Kreiger" Hammarström schrieb:

If i recall correctly, "_svn" is a workaround some people use for some
Microsoft product which couldn't handle dots in directory names.


Yep. See http://subversion.tigris.org/svn_1.3_releasenotes.html
-


The "_svn" hack is now officially supported: since some versions of
ASP.NET don't allow directories beginning with dot (e.g., ".svn", the
standard Subversion working copy administrative directory), the svn
command line client and svnversion now treat the environment variable
SVN_ASP_DOT_NET_HACK specially on Windows. If this variable is set (to
any value), they will use "_svn" instead of ".svn". We recommend that
all Subversion clients running on Windows take advantage of this
behaviour. Note that once the environment variable is set, working
copies with standard ".svn" directories will stop working, and will need
to be re-checked-out to get "_svn" instead.

0

Maxim, thanks a lot. It works!

Hello t800t8,

Go to Settings|General and add whatever pattern to
exluded files and folders
list.

------------------
Maxim Shafirov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Please sign in to leave a comment.