Changing scrollbar behavior

Hello,

I'm using PHPStorm 7.1 right now.  On the right side, there is the vertical scrollbar and the indicators that check for problems in the code.  If I hover over that with my mouse, I see a code snippet at that location.  If I click anywhere in that area, the editor window jumps to that section of the file.  Is there a way to change this so that if I click below the scrollbar it just pages down instead of jumping to that position in the file?  I can click and drag the scrollbar if I want to go to a certain area in the file, but is there a quick way with the mouse to page down?

Thanks

3 comments
Comment actions Permalink

Hi there,

Keyboard would be faster ...

In any case: you have to disable "Lense mode" (that preview tooltip) to have such pagination behavior back. Search Settings screen (search box is in top left corner) for "editor preview" (the full settings path for v8.0.2 is "Settings | Appearance & Behaviour | Appearance | Show editor preview tooltip")

0
Comment actions Permalink

It doesn't look like that setting changes the click behavior for me, it will still jump to the position I click instead of scrolling a page at a time.  It looks like that setting affected the popup, instead of showing the code at that location it just shows a summary of the messages from that location.  I'll keep looking around.  Maybe this is a change in version 8.

1
Comment actions Permalink

This didn't work for me either. I eventually discovered that I needed to search for "scrollbar " as well, then under "Actions" option that appears (see attachment) turn off the option "Window: Show code lens on scrollbar hover".

 

0

Please sign in to leave a comment.