Cannot seem to change mocha reporter being used by PhpStorm

The command line generated by the PhPSTorm run command is:

/usr/local/bin/node /Users/andymurdock/Documents/Projects/jbv3/node_modules/mocha/bin/_mocha -r node-define --ui bdd --reporter "/Users/andymurdock/Library/Application Support/WebIde80/NodeJS/js/mocha-intellij/lib/mochaIntellijReporter.js" /Users/andymurdock/Documents/Projects/jbv3/src/js-test/test

So it uses the standard reporter: mochaIntellijReporter.js

I would like to use mocha-istanbul:

Run

mocha
using
mocha-istanbul
as a reporter.

But my command line still includes the standard reporter when I use the "Extra Mocha options" field.

/usr/local/bin/node /Users/andymurdock/Documents/Projects/jbv3/node_modules/mocha/bin/_mocha -r node-define --reporter mocha-istanbul --ui bdd --reporter "/Users/andymurdock/Library/Application Support/WebIde80/NodeJS/js/mocha-intellij/lib/mochaIntellijReporter.js" /Users/andymurdock/Documents/Projects/jbv3/src/js-test/test

Does anyone know how to change the reporter in this way?

Please sign in to leave a comment.