Behat version: Not installed

Hi,

I'm trying to re configure behat to run some tests using a remote interpreter with vagrant. It was working fine before I formated my laptop.

Now when I set either the path to the behat.phar file or to the composer bin under the local setting I get "Behat version: Not installed".

If I do the same for the remote interpreter it works just fine (see screenshots attached)

As result of this when trying to run the tests I got the following error:

vagrant:///Users/jcalonso/Projects/test-project/usr/bin/php -dxdebug.remote_enable=1 -dxdebug.remote_mode=req -dxdebug.remote_port=9000 -dxdebug.remote_host=10.0.2.2 /home/vagrant/.phpstorm_helpers/behat.php --format PhpStormBehatFormatter --config /home/vagrant/test-project/behat.yml /vagrant/test-project/test/features/events/save_events.feature
Testing started at 16:58 ...
Can not find behat autoloader file by directory: '/home/vagrant/test-project/vendor/bin'

Process finished with exit code 1



Attachment(s):
Screen Shot 2014-11-18 at 17.20.46.png
Screen Shot 2014-11-18 at 17.20.37.png
9 comments
Comment actions Permalink

Please check that default interpreter is local when you are trying to update local behat version and attach output for "<path_to_selected_php> <path_to_behat_from_local_settings>  --version". As for running remote behat tests, where do you have composer autoload.php file on remote machine? Can you run remote behat tests with configured by phar?

0
Comment actions Permalink

Same error here: I got PhpStorm 2016.2, local php interpreters (5.5, 5.6, 7.0) and Behat 3.1 installed. When I try to set the path in PhpStorm Behat settings (local) to the Behat directory I always get the error: "Behat version: Not installed". Any ideas?

0
Comment actions Permalink

Hi there,

What idea.log has to say about it (it should contain more detailed error description). You can find it via "Help | Show Log in..." . Plus .. IDE itself should show more detailed error description (like in the ticket mentioned below).

What IDE build you are using exactly? This ticket seems similar (at least in general) -- https://youtrack.jetbrains.com/issue/WI-32189 . Could you try 2016.2.1 EAP build?

As possible alternative -- try PHAR version.

0
Comment actions Permalink

I have the same issue. Here is the error message :

 

WARN - pTestFrameworkVersionComponent -

[Symfony\Component\Config\Definition\Exception\InvalidConfigurationException]
The child node "sessions" at path "testwork.mink" must be configured.

 

Any help would be appreciated

0
Comment actions Permalink

Benoit, what does "php ./vendor/behat/behat/bin/behat -V" say? Does it through the same exception?

0
Comment actions Permalink

it says behat 3.4.1

Running behat from the command line is working fine. 

I would like to run it within phpstorm and that the steps are recognized. This project is installed with composer...

I have another project without composer that is working fine. 

 

 

0
Comment actions Permalink

Please attach a screenshot with:

1) your Behat configuration (similar to one posted here before)

2) the error you're getting (The child node "sessions" at path "testwork.mink" must be configured.)

0
Comment actions Permalink

 

I have tried different combinations here is one of them

 

0
Avatar
Vladimir Luchansky
Comment actions Permalink

Must be something related to Mink extension in behat.yml - is the configuration identical to the project where it does work properly?

0

Please sign in to leave a comment.