Webstorm 9 not honoring the Javascript indenting rules

I am using Webstorm from version 7. I recently upgraded to Webstorm 9 and the Javascript indenting is not working according to the settings. I have looked at all the Preferences and made sure the indent is 4 spaces. Still it will only indent the code by 2 characters instead of the internal standard/preference setting of 4 characters. Is this a bug? I am using Webstorm 9 on Mac.

I am hugely dissapointed by this and started editing Javascript now using Atom editor.

Hari

2 comments
Comment actions Permalink

Hi there,

Screenshot of your Code Style general settings (full page, not just a part of it) please.

Right now it sounds like values from .editorconfig file are overriding IDE settings (yes, it meant to be this way). If that's so -- either edit values in that .editorconfig file or disable it's support (option should be on that Code Style general settings page).

0
Comment actions Permalink

Thank you! You are awesome! That did the trick.

0

Please sign in to leave a comment.