Unable to open 5.0.2 .ipr in 5.1 build #4155

I have double-check to makes sure that all of my projects are in the directory that they were created when using IntelliJ 5.0.2.

I downloaded and installed IntelliJ 5.1 build #4155 without any issues.

In IntelliJ 5.1 build #4155, I try 'Open Project' or 'Reopen Recent Project' and nothing happens - no events, no CPU spikes, anything...

How do I properly open a project made with IntelliJ 5.0.2 in IntelliJ 5.1 build #4155?

Here is a sample .ipr file that I am trying to open:

4 comments

Hello Todd,

The most likely reason for the problem is that you have a third-party plugin
installed which is not compatible with IntelliJ IDEA 5.1. There have been
no incompatible changes in the project format between 5.0 and 5.1.

T> I have double-check to makes sure that all of my projects are in the
T> directory that they were created when using IntelliJ 5.0.2.
T>
T> I downloaded and installed IntelliJ 5.1 build #4155 without any
T> issues.
T>
T> In IntelliJ 5.1 build #4155, I try 'Open Project' or 'Reopen Recent
T> Project' and nothing happens - no events, no CPU spikes, anything...
T>
T> How do I properly open a project made with IntelliJ 5.0.2 in IntelliJ
T> 5.1 build #4155?
--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

Thank you!

That was the issue Dmitry. I greatly appreciate the quick response.

The plugin 'Struts Plugin' had caused the issue.

Question: In Settings->Plugins->Available, how do you just list the plugins that are compatible with 5.1 build #4155?

Thanks,

0

Hello Todd,

T> Thank you!
T>
T> That was the issue Dmitry. I greatly appreciate the quick response.
T>
T> The plugin 'Struts Plugin' had caused the issue.
T>
T> Question: In Settings->Plugins->Available, how do you just list
T> the plugins that are compatible with 5.1 build #4155?

If a plugin developer has not marked his plugin as incompatible with IDEA
5.1, there is no way for IDEA to determine this automatically. All versions
of the Struts plugin are marked as compatible with IDEA 5.1.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0

I don't understand how my plugin would be the cause of this. Did you take over the old configuration files from 5.0.2 when upgrading to 5.1? Which version of the plugin did you try to start in 5.1? The latest (V0.88) definitely works in 5.1.

Yann

0

Please sign in to leave a comment.