[#657:BUG] idea657.exe

Hi,

the native Installer in idea657.exe does not configure the system property
-Dsun.java2d.noddraw=true in idea.lax.
Without disabling direct draw in java2d the transparent mode of floating
windows
does not operate on win2k systems.
Appending "lax.nl.java.option.additional" with -Dsun.java2d.noddraw=true
solved the problem on my machine.

- Roland


5 comments
Comment actions Permalink

I have never been able to get transparency to work under Idea. What tool
windows exactly are supposed to be transparent?

"Roland Foerther" <roland.foerther@100world.com> wrote in message
news:ao18iq$2da$1@is.intellij.net...

Hi,

>

the native Installer in idea657.exe does not configure the system property
-Dsun.java2d.noddraw=true in idea.lax.
Without disabling direct draw in java2d the transparent mode of floating
windows
does not operate on win2k systems.
Appending "lax.nl.java.option.additional"

ith -Dsun.java2d.noddraw=true

solved the problem on my machine.

>

- Roland

>
>


0
Comment actions Permalink

Have you tried these steps?

- Make sure you have "-Dsun.java2d.noddraw=true" as a JVM argument
- Turn transparency options on in IDE Settings - Appearance
- Open a tool window (say the Structure one)
- Click the Float option in the upper right hand corner of the tool window (it looks like 2 overlapping squares)
- Now click back in the editor or on another tool window
- The floating Structure window should fade transparent according to the settings you selected.

Hope that helps!

Tobin

0
Comment actions Permalink

Great, works like a charm, thanks.

"Tobin Juday" <tsjuday@checkfree.com> wrote in message
news:6716635.1034178064687.JavaMail.jrun@is.intellij.net...

Have you tried these steps?

>

- Make sure you have "-Dsun.java2d.noddraw=true" as a JVM argument
- Turn transparency options on in IDE Settings - Appearance
- Open a tool window (say the Structure one)
- Click the Float option in the upper right hand corner of the tool

window (it looks like 2 overlapping squares)

- Now click back in the editor or on another tool window
- The floating Structure window should fade transparent according to the

settings you selected.
>

Hope that helps!

>

Tobin



0
Comment actions Permalink

I found that noddraw=true is no longer nec. in 1.4.1.
Has anyone else found this, or the opposite?

Christopher A. Longo wrote:

Great, works like a charm, thanks.

"Tobin Juday" <tsjuday@checkfree.com> wrote in message
news:6716635.1034178064687.JavaMail.jrun@is.intellij.net...

>>Have you tried these steps?
>>
>> - Make sure you have "-Dsun.java2d.noddraw=true" as a JVM argument
>> - Turn transparency options on in IDE Settings - Appearance
>> - Open a tool window (say the Structure one)
>> - Click the Float option in the upper right hand corner of the tool


window (it looks like 2 overlapping squares)

>> - Now click back in the editor or on another tool window
>> - The floating Structure window should fade transparent according to the


settings you selected.

>>Hope that helps!
>>
>>Tobin




--

Erb

==============================================================
"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

0
Comment actions Permalink

I took it out and still get transparency. Is transparency used anywhere
else in the app?

"Erb" <dont@evenbother.com> wrote in message
news:ao1jis$kfr$1@is.intellij.net...

I found that noddraw=true is no longer nec. in 1.4.1.
Has anyone else found this, or the opposite?

>

Christopher A. Longo wrote:

Great, works like a charm, thanks.

>

"Tobin Juday" <tsjuday@checkfree.com> wrote in message
news:6716635.1034178064687.JavaMail.jrun@is.intellij.net...

>
>>Have you tried these steps?
>>
>> - Make sure you have "-Dsun.java2d.noddraw=true" as a JVM argument
>> - Turn transparency options on in IDE Settings - Appearance
>> - Open a tool window (say the Structure one)
>> - Click the Float option in the upper right hand corner of the tool
>

window (it looks like 2 overlapping squares)

>
>> - Now click back in the editor or on another tool window
>> - The floating Structure window should fade transparent according to

the

>

settings you selected.

>
>>Hope that helps!
>>
>>Tobin
>
>
>

>
>

--

>

Erb

>

==============================================================
"Most of you are familiar with the virtues of a programmer.
There are three, of course: laziness, impatience, and hubris."
- Larry Wall
==============================================================

>


0

Please sign in to leave a comment.