Student license, can't activate product

Hi everyone!

I just applied for a student's license, got to the " JetBrains Product Pack for Students  " page.

I see the text saying "After downloading and installing the  software, simply run it and follow the on-screen prompts to sign in with  your JetBrains Account. You don't need a license key."

But when i download WebStorm, unpack and run (I'm using ubuntu 12.04  LTS) i never saw any instructions on how to activate the product for my  account, and if i accept the 30-day trial i can't find any place where  to sign in with my account or anything similar...

Is this normal? I didn't get any extra emails in my university's  account saying what to do to activate my account on the IDE.


Kind regards.

13 comments
Comment actions Permalink

Hi there,

I have no clue about student licenses but ...

1) You can register product by going to "Help | Register" .. or "Register" from Welcome screen.

2) There you should pick "JetBrains Account" option

3) Before that -- login to JetBrains account : https://account.jetbrains.com/ and check for the licenses that you have got there. Possibly you will have to click a link to generate SN/License first

If still nothing: please post screenshots and IDE version (in case if you are using old version which does not have JB Account activation option)

0
Comment actions Permalink

I want to use WebStorm, it seems it doesn't have the "jetbrains accoun" option when i open the Register dialog :/

I'm using the latets stable version, maybe i should try a beta for the next? is that available?

Thank you for your suggestion!

0
Comment actions Permalink

Lol WebStorm 9 beta doesn't even have the registration option...

I'm too poor to pay for the full license haha and this is the only IDE i need from jetbrains...

I guess i'm bad luck brian...

anyway, thanks for your help!

0
Comment actions Permalink

v9 is not a proper release yet -- still EAP stage (well, beta as of now).

Each EAP version have their own 30-days license -- which means that anyone can use it

Once v9 final will be officially released, the registration option will be available again.

0
Comment actions Permalink

At the point you accepted the 30 day trial, there was another option that should have been chosen instead, I believe. If I remember, there were 3 options, and the last one was what you wanted.

0
Comment actions Permalink

I looked carefully, at least for webstorm there wasn't any other options than 30 day trial and register with key

0
Comment actions Permalink

Hi,

I've got the same problem. I'm using a Windows 7 machine and Webstorm 8.0.5.

After the installation process I've got following possibilites to activate the product (see attachment license activation.png):
via license key or license server.
I tried the older version 7.0.3 also, same there.

Any clue how to fix this? If additional infos are needed, just say something.
In my account the student license is there and I installed it twice already in the past without any problems.



Attachment(s):
license activation.png
0
Comment actions Permalink

Sorry -- have no clue why you do not see it.

This is what I see when installing and running WeStorm v8.0.5 on Windows 7 x64 SP1 running in Virtual Machine under VMware Workstation (this Windows is clean: only few basic programs are installed -- it knows nothing about any previous JB products).
screen01.png

Once again: have no clue what is required to have this option showing up.

My only ideas:

  • internet access at all?
  • any proxies?
  • firewalls / antiviruses?


My thouhgs: JetBrains Account option requires internet access -- if it cannot connect to required host (likely over HTTPS) .. then it may not show this option as available.


In any case: please check what your "idea.log" file contains

0
Comment actions Permalink

Guys i found how to do it, go to the proxy settings and set it to automatic...

Well it seems that if you are working behind a proxy, the account authentication doesn't work, so you need to configure that...

It worked for me just with automatic, try other configurations if you want.

Regards

0
Comment actions Permalink

You are right, I'm sitting behind a proxy. If I change it to automatic I have no webaccess. Is there any possibility to get webstorm to use the proxy for the authentification process?

0
Comment actions Permalink

I also configured the proxy in the settings section now but this hasn't any influence in the activation screen...

error Message from idea.log is

INFO - dvertisement.PluginsAdvertiser - Connection timed out: connect
java.net.ConnectException: Connection timed out: connect
     at java.net.TwoStacksPlainSocketImpl.socketConnect(Native Method)
     at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
     at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
     at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
     at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
     at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
     at java.net.Socket.connect(Socket.java:579)
     at java.net.Socket.connect(Socket.java:528)
     at sun.net.NetworkClient.doConnect(NetworkClient.java:180)
     at sun.net.www.http.HttpClient.openServer(HttpClient.java:432)
     at sun.net.www.http.HttpClient.openServer(HttpClient.java:527)
     at sun.net.www.http.HttpClient.<init>(HttpClient.java:211)
     at sun.net.www.http.HttpClient.New(HttpClient.java:308)
     at sun.net.www.http.HttpClient.New(HttpClient.java:326)
     at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:996)
     at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:975)
     at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:850)
     at com.intellij.ide.plugins.RepositoryHelper.loadPluginsFromRepository(RepositoryHelper.java:72)
     at com.intellij.openapi.updateSettings.impl.pluginsAdvertisement.PluginsAdvertiser$2$1.run(PluginsAdvertiser.java:250)
     at com.intellij.openapi.application.impl.ApplicationImpl$8.run(ApplicationImpl.java:419)
     at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
     at java.util.concurrent.FutureTask.run(FutureTask.java:262)
     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
     at java.lang.Thread.run(Thread.java:745)
     at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:149)

0
Comment actions Permalink

Seems to be: https://youtrack.jetbrains.com/issue/IDEA-130598 .
Сheck that <path_to_java>/lib/security/cacerts is not empty.

0

Please sign in to leave a comment.