Keyboard Shortcuts Not Working?

Hello all,

I'm working with IDEA IntelliJ 4.5 and am having trouble getting certain keyboard shortcuts to work (others seem to work fine).

The shortcut I'm concerned with is CTRL-ALT-Left Arrow and CTRL-ALT-Right Arrow to page back and forth between files.

I've tried 3 different keyboards and don't get any response when I hit that key combination.

Has anyone experienced this problem or know of a way to fix it?

Much appreciated,
Chris

4 comments

Chris Paul wrote:

Has anyone experienced this problem or know of a way to fix it?


The most common cause for "broken" shortcuts are other applications grabbing the
keystrokes. Instant Messaging programs like ICQ and certain display drivers
(ATI) are known to do this.

Sascha

0

Hello Chris,

I'm working with IDEA IntelliJ 4.5 and am having trouble getting
certain keyboard shortcuts to work (others seem to work fine).

The shortcut I'm concerned with is CTRL-ALT-Left Arrow and
CTRL-ALT-Right Arrow to page back and forth between files.

I've tried 3 different keyboards and don't get any response when I hit
that key combination.

Has anyone experienced this problem or know of a way to fix it?


Some video drivers register Ctrl+Alt-* shortcuts for their actions,
thus preventing other applications from using these keys (ATI video
drivers and Intel Extreme Graphics are known to cause this).

The solution is to either locate the application that takes over these
keys and shut it down or assign different key combinations for actions
which do not work in Settings | Keymap.

So, it's rather your system configuration issue, than IDEA problem.


--
Serge Baranov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Chris Paul wrote:

Hello all,

I'm working with IDEA IntelliJ 4.5 and am having trouble getting certain keyboard shortcuts to work (others seem to work fine).

The shortcut I'm concerned with is CTRL-ALT-Left Arrow and CTRL-ALT-Right Arrow to page back and forth between files.

I've tried 3 different keyboards and don't get any response when I hit that key combination.

Has anyone experienced this problem or know of a way to fix it?

Much appreciated,
Chris


I had these particular key combinations broken quite frequently
in earlier builds (maybe a year ago or so). It always happened
after working with IDEA for a longer time, and shutting down and
restarting the IDE always "fixed" it.
However, with more recent build I no longer experienced this.

Regards,
Jens

0

Can someone please lis the steps to identify which applications are over-writing application shortcuts?

0

Please sign in to leave a comment.