Debug Window Missing

Good morning all,

Last friday I was running some tests, and for some reason I clicked on some option in the Debug/Run window and it dissapeared; I tought it was just "hidden", but looks like the entire feature doesn't even exists.

I spent the weekend trying to restore it by editing the ./idea files but no luck; also google is not helping.  

Could you guys shade some light over here, please.

Thanks in advance.


Here you can see there's no option to show the 'Debug' window :(

NoDebugWindow.jpg

8 comments
Comment actions Permalink

Hi there,

I have no idea (at all) what you have clicked there .. but this is normal situation: the debug tool window is not listed there until created. So.. start debugging and it will appear.

1
Comment actions Permalink

Yes, the window appears doing that,... so I'll just use it like that... but anyway it's weird to not be able to put the window back.

Thanks Andriy,

0
Comment actions Permalink
it's weird to not be able to put the window back

What do you mean?

What is the benefit of accessing it outside of debug session (except, maybe, the fact that you can add new or delete existing watches)?

I personally do not remember seeing it there at all. At the same time I have to say that I have never actually looked for it there: I just start debugging and it appears; where it is located when I'm not debugging I do not care (as I do not need it when I'm coding).

0
Comment actions Permalink

Some times the debug window does not show up even when it hits a break point and clearly storm is started debugging. We really need a way to open tabs regardless of whether or not debugging has started as a remedy for this issue. 

When this happens my only option is to use hotkeys to step through code or to use the Run menu and I can't see any variables.

1
Comment actions Permalink

@Richwandell

I personally never faced such issue myself (Windows 10 OS; using PhpStorm since 0.6 version or so).

Consider reporting this bug (not appearing debug tool window during debug session) to the Issue Tracker .

If you have faced this issue recently and remember when it happened (the time), check idea.log as well for some possible hints (exceptions etc)

1
Comment actions Permalink

Andriy Bazanov

This a persistent issue with Intellij and it happens sometimes without any config change. There should be an easier way to show/hide debug window.

Solution :

1> put a debugger and start debugging your code

2> In services tab look for the icon in following screenshot. Click on it for the dropdown to appear and select "Restore Default Layout"

0
Comment actions Permalink

This is suddenly killing me.  I upgraded from 15 to 20 and as of this morning I no longer have a debug tool.  I can reach the functions through the run menu but it's ponderous.  Switch back to 15 didn't help, no debugger there anymore either.  

view -> tool windows

No debugger even when stopped at a breakpoint.  

No option to restore default layout.  

Maybe just point me at the config file where that layout is defined?  I can't figure out how to restore this and I really need that debugger tool.  

I'm on a mac running the current version of Catalina OS

....

this is truly absurd.  I just spent the last hour and a half chasing this problem and I went to go create screen shots for you and the debugger tool popped up.  It's now back pinned to the services, in the view -> tool windows and comes up with command-5.

My ask still stands.  What file defines this layout? 


0
Comment actions Permalink

@Jim

>My ask still stands. What file defines this layout? 

That's a good question. AFAIK the layout is project specific.

This is what I see for my IDE-Test project.

Do this while IDE is closed (as it overwrite the settings when closing the project/IDE).

  1. PROJECT_ROOT/.idea/workspace.xml -- open that file and look for <component name="ProjectId" node
  2. Make a note of the id attribute value (e/g. 1OVsD6SX2AzSazagHBXOTEBLIaW)
  3. Go to the IDE settings folder (on Windows that would typically be "C:\Users\USERNAME\AppData\Roaming\JetBrains\PhpStorm2020.1" and look for "workspace" subfolder.
    For MacOS / Linux -- look at https://www.jetbrains.com/help/phpstorm/tuning-the-ide.html#config-directory and/or https://intellij-support.jetbrains.com/hc/en-us/articles/206544519-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs
    Based on the above on Mac that should be "~/Library/Application Support/JetBrains/PhpStorm2020.1" (that's for PhpStorm 2020.1)
    NOTE 1: if you install IDE using Toolbox App, then the path might be different, check that by using menu item under the cog icon there.
    NOTE 2: if you are using some IDE Settings Sync plugin it may store them in a different folder (e.g. in a subfolder)
  4. Locate that file with the id attribute value from step #2 (e.g. "workspace\1OVsD6SX2AzSazagHBXOTEBLIaW.xml")
  5. Inside that file look for <component name="ToolWindowManager"> node. The Debug toolwindow will be a node with id="Debug"
0

Please sign in to leave a comment.