Issue: PHPStorm 8 and Ubuntu 14.04 Won't Open From Launch Bar

Hi,

I've just upgraded to PHPStorm 8, from 7.

I am having to run the command everytime i want to launch phpstorm.

./phpstorm.sh < Works

When i lock it to the launcher and quit, and try to open it from the launcher it will not open.

Can you help me troubleshoot this issue.

Thanks.

5 comments
Comment actions Permalink

Hi there,

Have a look at Tools menu (in PhpStorm)  -- there should be a command for it.

0
Comment actions Permalink

I tried

Tools > Create Command Line Launcher

it didint create any new launcher for me.

Like is this normal, is it worth completly removing phpstorm and reinstalling it?

0
Comment actions Permalink

No -- that launcher is for launching IDE from command line only (i.e. "pstorm /path/to/folder/or/file")

I thought there is another "create launcher" command. Apparently I was wrong.

Like is this normal, is it worth completly removing phpstorm and reinstalling it?

I would definitely try reinstalling it (backup your IDE settings first and remove that icon from launcher bar before re-installing it).

0
Comment actions Permalink

How do u uninstall phpstorm 8 on ubuntu?

http://wiki.jetbrains.net/intellij/Installing_and_running_PHPStorm_on_Ubuntu

The above shows me how to install it, but i can't seem to find how i can properly uninstall it.

thanks.

0
Comment actions Permalink

AFAIK you just delete the folder with PhpStorm files -- it's not Windows where it has dedicated installer/uninstaller -- here you just unpack into empty folder and run (Install instructions are also shown on Download page).

The folders with IDE config/caches/etc are described here: https://intellij-support.jetbrains.com/entries/23358108-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs

To preserve your settings: just backup "config" subfolder (or, if you prefer, use "File | Export/Import Settings" commands in IDE). The "system" folder can be safely deleted as it will be regenerated on IDE launch/project opening.

0

Please sign in to leave a comment.