CVS module in IDEA 5.0.2 too sensitive?

Hi I have a problem with CVS module - I am not sure if this is caused by IDEA 5, but it did not happen when I was using IDEA 4.5.

When I fetch code using command line client I get:

My concern is the first line "permission denied". It allows me to work from command line.
I can also check in,check out, see file history in IDEA.
However I CANNOT execute "Compare with the same repository version" because I get error from IDEA:

So I assume something in the CVS module is "too sensitive".

Has anyone the same problem? I know the answer should be "fix the perimssions in CVS" but this is handled by different department and can take ages....

Best regards,
Adam

3 comments

recurse.c:639: failed assertion `strstr ( repository, "/./" ) == NULL'


I would guess, you are using a rather old CVS server, which causes this problem.

Tom

0

You are absolutely right. But you can figure out the chances of updating CVS, if I cannot even ask them to fix permissions.

Is there any hope for me? :)
Adam

0

I have just checked - the same setup is working in IDEA 4.5 so this is a really bad surprise.

Adding to this the fact that we had to pay for the update to 5.0 makes me really disappointed

0

Please sign in to leave a comment.