How to get WebStorm to ignore node modules

This has long since got to the point where it's annoying so I need help....

My projects are NEVER node projects but they ALL use node/grunt like 'Ant' as a simple Task runner.

WS is great in the way I can launch a Grunt Task from inside the IDE.

But ... it always insists on including every file  in node modules for things like intellisense, which means they are now as good as useless.

Everytime I restart WS I have to go into Project Settings/Javascript/libraries and deselect "MyApp node_modules"

I have also tried setting WS to ignore the folder.

It all makes no  difference, as soons as I restart WS all the node modules are back again...


using WS 8.0.4

tks
Rob

1 comment
Comment actions Permalink

Hello!

please try WebStorm 9 EAP (http://confluence.jetbrains.com/display/WI/WebStorm+9+EAP) - https://youtrack.jetbrains.com/issue/WEB-11605 is fixed there.
Note that you need to follow the steps below to make this work with EAP:

  • remove library '<module name> node_modules' in "Settings | Languages and Frameworks | JavaScript | Libraries";
  • mark node_modules/ directory as excluded.
0

Please sign in to leave a comment.