IntelliJ 5.x performance on Mac

I have been using IDEA for a number of years now and have been reasonably happy with it (meaning that I still have issues with it, but its the best IDE available for writing Java code). However, with 5.0.. I am running into problems that severely affect my ablity to be productive.

Is anyone else having problems? Its not uncommon for IDEA to just go away in the middle of typing code for upwards of 10-15 seconds even though the memory meter shows that I am nowhere close to running out of memory. Right clicking on a directory to do a find.. sometimes I click and it takes 10 seconds for the menu to appear! Hitting Command+N and searching for a file.. after I select the file, it can take up to 10 seconds for the file to actually load in the editor.

I am running a PowerBook G4 (Aluminum) running at 1.6GHZ with 1GB of RAM. I have set the memory to start at 256MB and max at 512M.

I am so desperate to make this work that I have trimmed my plugins to the bear minimum and I have attempted to turn off most of the code inspections and it makes no difference.

I am tempted to go back to 4.5, but I really love the perforce integration in 5.0. It finally works the way it should.

Can IDEA help those of us who are using 5.0 to optimize this thing to run reasonably? Its just not acceptable to have 10+ second delays for common operations on reasonable hardware. If this continues, I am going to have to start looking at alternatives like Eclipse ]]>.

Can anyone help me? Please? :)

Thanks,
--> John

2 comments

To me, this sounds like a problem with P4 integration. You should see if it's
better when you disable it. If this is the problem, until JB can make the P4
stuff asynchronous, you should try to improve the network connection to the P4
server.

John Townsend wrote:

I have been using IDEA for a number of years now and have been reasonably happy with it (meaning that I still have issues with it, but its the best IDE available for writing Java code). However, with 5.0.. I am running into problems that severely affect my ablity to be productive.

Is anyone else having problems? Its not uncommon for IDEA to just go away in the middle of typing code for upwards of 10-15 seconds even though the memory meter shows that I am nowhere close to running out of memory. Right clicking on a directory to do a find.. sometimes I click and it takes 10 seconds for the menu to appear! Hitting Command+N and searching for a file.. after I select the file, it can take up to 10 seconds for the file to actually load in the editor.

I am running a PowerBook G4 (Aluminum) running at 1.6GHZ with 1GB of RAM. I have set the memory to start at 256MB and max at 512M.

I am so desperate to make this work that I have trimmed my plugins to the bear minimum and I have attempted to turn off most of the code inspections and it makes no difference.

I am tempted to go back to 4.5, but I really love the perforce integration in 5.0. It finally works the way it should.

Can IDEA help those of us who are using 5.0 to optimize this thing to run reasonably? Its just not acceptable to have 10+ second delays for common operations on reasonable hardware. If this continues, I am going to have to start looking at alternatives like Eclipse <shudder>.

Can anyone help me? Please? :)

Thanks,
--> John

0

Nope, I have similar hardware (G4 PB/1.5GHz/2GB) and use it as my main
development machine with Mac OS 1.4.3/Java 1.5. I'm running IDEA 5.0.2
all day with 1-3 projects with 5-15 modules each with now but I had
none of the problems described. It's sometimes a bit more sluggish than
4.5 but it's definitely nothing that could be measurable in seconds...

any plugins that could screw up possibly?

O

On 2005-11-10 18:16:19 +0100, John Townsend <no_mail@jetbrains.com> said:

I have been using IDEA for a number of years now and have been
reasonably happy with it (meaning that I still have issues with it, but
its the best IDE available for writing Java code). However, with 5.0..
I am running into problems that severely affect my ablity to be
productive.

Is anyone else having problems? Its not uncommon for IDEA to just go
away in the middle of typing code for upwards of 10-15 seconds even
though the memory meter shows that I am nowhere close to running out of
memory. Right clicking on a directory to do a find.. sometimes I click
and it takes 10 seconds for the menu to appear! Hitting Command+N and
searching for a file.. after I select the file, it can take up to 10
seconds for the file to actually load in the editor.

I am running a PowerBook G4 (Aluminum) running at 1.6GHZ with 1GB of
RAM. I have set the memory to start at 256MB and max at 512M.
I am so desperate to make this work that I have trimmed my plugins to
the bear minimum and I have attempted to turn off most of the code
inspections and it makes no difference.
I am tempted to go back to 4.5, but I really love the perforce
integration in 5.0. It finally works the way it should.
Can IDEA help those of us who are using 5.0 to optimize this thing to
run reasonably? Its just not acceptable to have 10+ second delays for
common operations on reasonable hardware. If this continues, I am going
to have to start looking at alternatives like Eclipse <shudder>.
Can anyone help me? Please? :)

Thanks,
--> John



0

Please sign in to leave a comment.