CVS Hangs and won't update

The CVS plugin in IntelliJ IDEA 4.5 has stopped working for me since I installed Windows XP SP2 (and subsequently uninstalled it.) Every time I try to browse our CVS repository or update my project IDEA just hangs indefinitely.

I found that it is putting the following lines into the "idea.log" file, but they do not suggest a remedy for me. I hope someone knows how to resolve this, since I have already wasted hours trying to find what has changed? WinCVS and SmartCVS still work perfectly, it only seems to be hanging with IDEA. I have uninstalled and reinstalled IDEA multiple times, deleted the config and cache files, and even tried using older EAP build. Nothing seems to help, although this used to work great on this same machine.

2004-08-11 23:48:08,648 INFO - ort2.javacvsImpl.io.ReadThread - Starting CvsReadThread Thread[CvsReadThread,10,Idea Thread Group], atEnd: false, firstIndex: 0, lastIndex: 0, exception: null, closed: false
2004-08-11 23:48:08,710 INFO - ort2.javacvsImpl.io.ReadThread -
java.net.SocketException: No buffer space available (maximum connections reached?): recv failed
at java.net.SocketInputStream.socketRead0(Native Method)
at java.net.SocketInputStream.read(SocketInputStream.java:129)
at java.io.BufferedInputStream.read1(BufferedInputStream.java:220)
at java.io.BufferedInputStream.read(BufferedInputStream.java:277)
at java.io.FilterInputStream.read(FilterInputStream.java:90)
at com.intellij.cvsSupport2.javacvsImpl.io.ReadThread.run(ReadThread.java:94)
2004-08-11 23:48:08,710 INFO - ort2.javacvsImpl.io.ReadThread - Stopping CvsReadThread Thread[CvsReadThread,10,Idea Thread Group], atEnd: false, firstIndex: 0, lastIndex: 0, exception: java.net.SocketException: No buffer space available (maximum connections reached?): recv failed, closed: false

Please let me know if you have any solutions to suggest. I am desperate to have normal CVS capabilities working in my IntelliJ IDEA.

Thanks,
Rick Ross
rick@javalobby.org

1 comment
Comment actions Permalink

Was this ever fixed? I have the same problem with build 3542 on WindowsXP SP2.

0

Please sign in to leave a comment.