Tagdir cannot be resolved in JSP

Hi,

Using IDEA 5.02 I have in my jsp files the following declaration for an include tagfile:

<%@ taglib prefix="template" tagdir="/WEB-INF/tags/template" %> <-- this is accepted without error


The problem is when I reference this tagfile I get the error message "Cannot resolve symbol"

Example:

<template:header/> <-- cannot resolve symbol error here.

The setup looks correct, just not working with these tagfiles. Is this suppose to work? anyone else have this working?

thx.
Steve.

4 comments

You have header.tag or header.tagx files there? if yes, then, please,
check out that tag dir is present in web resource directory.

Steven Pannell wrote:

Hi,

Using IDEA 5.02 I have in my jsp files the following declaration for an include tagfile:

<%@ taglib prefix="template" tagdir="/WEB-INF/tags/template" %> <-- this is accepted without error


The problem is when I reference this tagfile I get the error message "Cannot resolve symbol"

Example:

<template:header/> <-- cannot resolve symbol error here.

The setup looks correct, just not working with these tagfiles. Is this suppose to work? anyone else have this working?

thx.
Steve.



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Hi,

The tag file is there and the web resources directory is set as follows:

(resource dir) (path)
D:\webapps\myweb\WEB-INF /WEB-INF

The fact that the tagfile is working in my JSP file would indicate to me that there is nothing major wrong with my set up. Just intelliJ does not seem to identify the tag files.

0

I've always had problems of a similar nature. We use Webwork and no matter
what I try, the jsps are always spattered with red marks. Our project is
a Web project. The tld is in the /web-inf/lib directory, which is beneath
the content root. The taglib directive is fine as far as IntelliJ is concerned,
but all of the usages are unresolved.

Tox

Hi,

The tag file is there and the web resources directory is set as
follows:

(resource dir) (path)
D:\webapps\myweb\WEB-INF /WEB-INF
The fact that the tagfile is working in my JSP file would indicate to
me that there is nothing major wrong with my set up. Just intelliJ
does not seem to identify the tag files.



0

JIRA issue with fresh project of two file not working anyone?

Tony Johnson wrote:

I've always had problems of a similar nature. We use Webwork and no
matter what I try, the jsps are always spattered with red marks. Our
project is a Web project. The tld is in the /web-inf/lib directory,
which is beneath the content root. The taglib directive is fine as far
as IntelliJ is concerned, but all of the usages are unresolved.

Tox

>> Hi,
>>
>> The tag file is there and the web resources directory is set as
>> follows:
>>
>> (resource dir) (path)
>> D:\webapps\myweb\WEB-INF /WEB-INF
>> The fact that the tagfile is working in my JSP file would indicate to
>> me that there is nothing major wrong with my set up. Just intelliJ
>> does not seem to identify the tag files.
>>




--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.