Why warning: PhpStorm v8 extension *.blade.php was reassigned to Blade?

Hi, I expect this is a real noob dumb question, but every time I start up I get this warning appears:
"File type recognized: File extension *.blade.php was reassigned to Blade (Revert)"
(in phpStorm version 8.0.1 running Windows 7)

Should I be changing some IDE setting to remove this warning?
(In Settings/File Types I have the   *.blade.php filetype set in Blade and "Filetypes supported viaTextMate Bundles", but if I remove the latter I get no coloring)

Thanks for any help!

3 comments
Comment actions Permalink

Hi there,

PhpStorm v8 has proper support for Blade templates -- please remove one from TextMate bundles (as well as xorresponding bundle itself).

but if I remove the latter I get no coloring

Screenshots, please, of your related settings as well as such file  (whole tab, so that file icon can also be seen)

0
Comment actions Permalink

Andriy,
Thanks for such a quick reply - and you gave me the hint to resolve this.

Just removing the file association to *.blade.php was not enough, but de-selecting the "Textmate Bundles" from plugins and restarting phpStorm works.
(In fact, re-enabling Textmate Bundles can then be done if needed for another purpose, as it does NOT add the association back in to phpStorm v8)
So now no warning!
Many thanks from the U.K (still including Scotland!)

0
Comment actions Permalink

Yeah -- watched that live yesterday. Pretty close (45% vs 55%) and big turnout (around 85%) -- compared to usual arround/under 50% on general elections in England.

0

Please sign in to leave a comment.