Version hell with behat/mink in 8 EAP

Hi,
I am quite new to behat etc, but trying to set this up in the latest phpStorm PS-138-1901
I cannot find the right combination to install all the pieces for:
Behat, with Mink, with goutte and selenium2 drivers
Can anyone tell me a _compatible_ set of packages to use with Composer, and in which order to add them to my project?
(I am sure Jetbrains must have tested with Mink/goutte/selenium2, so what versions work together??)
Please help!
Thanks from the U.K
Chris

2 comments
Comment actions Permalink

In Mink composer.json is:

{
    "require": {
        "behat/behat": "2.4.*@stable",
        "behat/mink": "1.4.*@stable",
        "behat/mink-extension": "*",
        "behat/mink-goutte-driver": "*",
        "behat/mink-selenium2-driver": "*"
    },
    "minimum-stability": "dev",
    "config": {
        "bin-dir": "bin/"
    }
}

You can try this one

Also here is the documentation:
https://github.com/Behat/en-mink.behat.org/blob/master/index.rst

0
Comment actions Permalink

Thanks very much, I will use that config.
Best Regards
Chris

0

Please sign in to leave a comment.