LiveEdit plugin not working with CSS files

Live Edit doesn't work with external CSS files anymore. It happened some day, that it just doesn't work anymore. I have updated and reinstalled PHPStorm, the Live Edit Plugin and the Chrome IntelliJ Plugin, nothing changed anything.
I am using PHPStorm 7.1.3 and the LiveEdit Plugin 1.17.133.1 (on Mac)
I even tried the PHPStorm 8 EAP and the lasted version of the LiveEdit plugin. There I don't even see the "LiveEdit" entry in the View menu.

I'm quite furious that this bug exists and makes the LiveEdit plugin useless for me. I Don't know if I am the only one using the plugin or whatever, this has to fixed!

I even tried PHPStorm on Windows, same there!

Install PHP Storm 7, Install the LIveEdit Plugin from the Settings Plugin Section, restart PhpStorm. Install google chrome, install the IntelliJ Debug Plugin.

Create a new HTML5 Boilerplate Project in PHPStorm and configure a JavaScript Debug session using a local XAMPP/MAMP webserver (project has to be in htdocs of course).

Run the Debug session. You can change stuff (html, css, js) in the index.html and the view will refresh in Chrome (reloading the page), but if you change something in the main.css file the changes won't be reflected in Chrome. You have to manually reload the page in Chrome.

Month ago, when the plugin was working changing something in main.css would have been immediately updated in Chrome!

I have a project to finish today and i'm running out of time. And because this plugin doesn't so, what it should I am losing even more time... and I already wasted alsmost 2 hours TODAY trying everything to get the plugin working again.

Please do something about that! I paid for PHPStorm and without LIveEdit working I might have to look for alternatives in the future :-(

2 comments
Comment actions Permalink

http://youtrack.jetbrains.com/issue/WEB-11393 is fixed in PHPStorm 8, so it works for CSS files in the recent EAP.
You need to make sure to install the latest Live Edit plugin, then set the 'Update' option in Settings/Debugger/Live Edit to 'Auto in (ms)'. I'd also suggest enabling 'restart if hotswap fails'. Then start the debug session (as before) and edit your files

0
Comment actions Permalink

Thank you for your adivce. Today I have tested Live Edit again with PhpStorm 8 EAP Build 138.2071 and Live Edit Plugin version 2.0.9 (previously I had version 2.0.8). I confirmed the settings (set to auto) and now Live Edit works again!
It seems the update from 2.0.8 to 2.0.9 fixed the problem. I hope it stays that way and the final verion of PhpStorm 8 is released soon.

0

Please sign in to leave a comment.