PHPStorm 7.1.3 zend debug times out too soon

I installed PHPStorm on my new computer a couple of months ago and I have Zend Debugger working except for one problem that I can't seem to be able to resolve.  When I start debuging using the firefox zend tool bar, I only get about 30 seconds before the session aborts.  I know my old computer used to take 4 or 5 minutes before the session aborted.  Surly there is a way to configure the timeout?

Thanks for any help.

4 comments
Comment actions Permalink

Hi there,

This kind of stuff usually controlled by the actual web server (the one that launches PHP to execute requested script) and not IDE.

What is your web server and how it launches PHP?

0
Comment actions Permalink

I am running windows 7 and IIS 7.5.  I compared the timeouts for my site and the application pool on my old computer and I can't see any difference. Not sure where else to change the timeouts.

0
Comment actions Permalink

It has nothing to do with app pool config.

If it's controlled by zend debugger .. then I cannot advise here).

If it's server (I strongly believe it is the case) then check your FastCGI settings:

IIS Manager | FastCGI | your PHP entry | Edit...

Here is screenshot from my dev machine: 700/900 seconds is more than enough for me
screen01.png

0
Comment actions Permalink

That fixed it.  Thanks for your help.

0

Please sign in to leave a comment.